aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl-fw/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:05:40 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:05:40 +0000
commit0938233fcdef67d969f9429a10761cc640c6d56d (patch)
tree7ccad7e4c703260f288aeff5b8232b387fa7cc84 /package/kernel/lantiq/ltq-vdsl-fw/Makefile
parent787120e3a3e3cfdf26efc22c652743f5d91840fd (diff)
downloadupstream-0938233fcdef67d969f9429a10761cc640c6d56d.tar.gz
upstream-0938233fcdef67d969f9429a10761cc640c6d56d.tar.bz2
upstream-0938233fcdef67d969f9429a10761cc640c6d56d.zip
lantiq: get rid of ltq-vdsl-fw
Because of dsl-vrx200-firmware-xdsl-* there's no need anymore to download a dsl firmware at runtime. Signed-off-by: Andre Heider <a.heider@gmail.com> SVN-Revision: 47851
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl-fw/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-fw/Makefile40
1 files changed, 0 insertions, 40 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-fw/Makefile b/package/kernel/lantiq/ltq-vdsl-fw/Makefile
deleted file mode 100644
index 6404067707..0000000000
--- a/package/kernel/lantiq/ltq-vdsl-fw/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ltq-vdsl-fw
-PKG_VERSION:=1
-PKG_RELEASE:=1
-
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ltq-vdsl-vr9-fw-installer
- TITLE:=Firmware installer
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=@TARGET_lantiq_xrx200 +kmod-ltq-vdsl-vr9
-endef
-
-define Build/Prepare
- $(INSTALL_DIR) $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)
-endef
-
-define Build/Compile
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
- $(MAKE) -C $(PKG_BUILD_DIR)
-endef
-
-define Package/ltq-vdsl-vr9-fw-installer/install
- $(INSTALL_DIR) $(1)/sbin
- $(CP) $(PKG_BUILD_DIR)/w921v_fw_cutter $(PKG_BUILD_DIR)/vdsl_fw_install.sh $(1)/sbin/
-endef
-
-$(eval $(call BuildPackage,ltq-vdsl-vr9-fw-installer))