aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-ifxos
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-03-03 00:22:49 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-03 00:53:35 +0100
commitc8abbf1e225757b07b7c0e2bc7f6f9f2c9eb5dea (patch)
tree9c4169083a78bbc499d5c06063276316858bdafd /package/kernel/lantiq/ltq-ifxos
parentc6162fdc501bacd3b1409166b12e38ba55ebd548 (diff)
downloadupstream-c8abbf1e225757b07b7c0e2bc7f6f9f2c9eb5dea.tar.gz
upstream-c8abbf1e225757b07b7c0e2bc7f6f9f2c9eb5dea.tar.bz2
upstream-c8abbf1e225757b07b7c0e2bc7f6f9f2c9eb5dea.zip
lantiq: ltq-ifxos: Do not force O3 build any more
Do not force to build with O3 optimization any more, but take what was selected by the OpenWrt build system. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/lantiq/ltq-ifxos')
-rw-r--r--package/kernel/lantiq/ltq-ifxos/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-ifxos/patches/020-no-O3.patch19
-rw-r--r--package/kernel/lantiq/ltq-ifxos/patches/200-Fix-app-compilation-failure-from-inclusion-of-wrong-.patch5
3 files changed, 20 insertions, 6 deletions
diff --git a/package/kernel/lantiq/ltq-ifxos/Makefile b/package/kernel/lantiq/ltq-ifxos/Makefile
index 43eb53c542..bd4f08da83 100644
--- a/package/kernel/lantiq/ltq-ifxos/Makefile
+++ b/package/kernel/lantiq/ltq-ifxos/Makefile
@@ -8,7 +8,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=lib_ifxos
PKG_VERSION:=1.5.19
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_NAME)/archive/v$(PKG_VERSION)
diff --git a/package/kernel/lantiq/ltq-ifxos/patches/020-no-O3.patch b/package/kernel/lantiq/ltq-ifxos/patches/020-no-O3.patch
new file mode 100644
index 0000000000..d2e816f5c0
--- /dev/null
+++ b/package/kernel/lantiq/ltq-ifxos/patches/020-no-O3.patch
@@ -0,0 +1,19 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -45,8 +45,6 @@ endif !HAVE_GCC
+
+ if ENABLE_DEBUG
+ used_gcc_cflags += -O1 -g
+-else
+-used_gcc_cflags += -O3
+ endif
+
+ AM_CFLAGS = \
+@@ -92,7 +90,6 @@ endif
+ drvifxos_additional_cflags=\
+ -DLINUX \
+ -D__LINUX__ \
+- -O \
+ -D__KERNEL__ \
+ -DMODULE \
+ -DEXPORT_SYMTAB
diff --git a/package/kernel/lantiq/ltq-ifxos/patches/200-Fix-app-compilation-failure-from-inclusion-of-wrong-.patch b/package/kernel/lantiq/ltq-ifxos/patches/200-Fix-app-compilation-failure-from-inclusion-of-wrong-.patch
index dee3482e4f..5d661db861 100644
--- a/package/kernel/lantiq/ltq-ifxos/patches/200-Fix-app-compilation-failure-from-inclusion-of-wrong-.patch
+++ b/package/kernel/lantiq/ltq-ifxos/patches/200-Fix-app-compilation-failure-from-inclusion-of-wrong-.patch
@@ -37,8 +37,6 @@ Ref: https://bugs.lede-project.org/index.php?do=details&task_id=1196
src/Makefile.am | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
-diff --git a/src/Makefile.am b/src/Makefile.am
-index f95668f..d232e7f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,11 +14,7 @@ lib_LIBRARIES = libifxos.a
@@ -54,6 +52,3 @@ index f95668f..d232e7f 100644
if HAVE_GCC
---
-1.8.3.1
-