aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/hwmon-gsc
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-05 23:22:47 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 14:23:33 +0100
commit4159054fbbf8a7176eaf3dd4467c5b0db70769d0 (patch)
tree23742b8265e1613b76b76144ab1c91060abd2ae6 /package/kernel/hwmon-gsc
parentdffbe668ab321c76c041aa15ca8b753deab2c4c5 (diff)
downloadupstream-4159054fbbf8a7176eaf3dd4467c5b0db70769d0.tar.gz
upstream-4159054fbbf8a7176eaf3dd4467c5b0db70769d0.tar.bz2
upstream-4159054fbbf8a7176eaf3dd4467c5b0db70769d0.zip
kernel: make kmod-hwmon-core selected by dependent modules
Currently kmod-hwmon-* will not get into images unless kmod-hwmon-core is added to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to "select", we do not have the issue anymore. Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES and similar variables, as it is now pulled by dependent modules such as: - kmod-hwmon-gpiofan - kmod-hwmon-lm63 - kmod-hwmon-lm75 - kmod-hwmon-lm85 - kmod-hwmon-lm90 Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx, adjust line wrapping] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel/hwmon-gsc')
-rw-r--r--package/kernel/hwmon-gsc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/hwmon-gsc/Makefile b/package/kernel/hwmon-gsc/Makefile
index 454f685f8f..95f6fab4c0 100644
--- a/package/kernel/hwmon-gsc/Makefile
+++ b/package/kernel/hwmon-gsc/Makefile
@@ -8,7 +8,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/hwmon-gsc
SUBMENU:=Hardware Monitoring Support
- DEPENDS:=@TARGET_imx6||TARGET_cns3xxx kmod-hwmon-core +kmod-i2c-core
+ DEPENDS:=@TARGET_imx6||TARGET_cns3xxx +kmod-hwmon-core +kmod-i2c-core
TITLE:=Driver for the Gateworks System Controller
AUTOLOAD:=$(call AutoLoad,60,gsc)
FILES:=$(PKG_BUILD_DIR)/gsc.ko