aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/ath10k-ct
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-03-22 23:24:42 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-23 22:08:22 +0100
commitdd8bf0cf6457c5893142a5a2b48f81c53fde0bcc (patch)
tree2447efd13b100c8aab5329b57dd91327e3adca99 /package/kernel/ath10k-ct
parentd15b09aab8a2aedeac2a6fb1e872ae975c9baa42 (diff)
downloadupstream-dd8bf0cf6457c5893142a5a2b48f81c53fde0bcc.tar.gz
upstream-dd8bf0cf6457c5893142a5a2b48f81c53fde0bcc.tar.bz2
upstream-dd8bf0cf6457c5893142a5a2b48f81c53fde0bcc.zip
ath10k-ct: fix module depends
PKG_EXTMOD_SUBDIRS should be set to the sub directory where the kernel module gets build in, for the ath10k-ct driver this changed in commit 3888e77c1c68 from ath10k to ath10k-4.13. Without this fix the depends line of the ath10*.ko modules is empty and the kernel module load system will not automatically load the depended modules like mac80211. Fixes: 3888e77c1c68 ("ath10k-ct driver: use dma_alloc_coherent, 4.13 based driver") Fixes: 23a388fe41ec ("ath10k-ct: Force loading mac80211 and ath modules.") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/ath10k-ct')
-rw-r--r--package/kernel/ath10k-ct/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index 00931175c2..1725bb7d17 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -12,15 +12,15 @@ PKG_SOURCE_DATE:=2018-03-16
PKG_SOURCE_VERSION:=30827f7d5b9841905c4efe918da2d95fc518c921
PKG_MIRROR_HASH:=aac023d7f9b09becf27058b1d09ae6d068b14bb6f10c5b5a248c7ee5ecff04dc
-PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
-PKG_BUILD_PARALLEL:=1
-PKG_EXTMOD_SUBDIRS:=ath10k
-
# Build the 4.13 ath10k-ct driver version. Other options are "-4.9", or
# leave un-defined for 4.7 kernel. Probably this should match as closely as
# possible to whatever mac80211 backports version is being used.
CT_KVER="-4.13"
+PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
+PKG_BUILD_PARALLEL:=1
+PKG_EXTMOD_SUBDIRS:=ath10k$(CT_KVER)
+
STAMP_CONFIGURED_DEPENDS := $(STAGING_DIR)/usr/include/mac80211-backport/backport/autoconf.h
include $(INCLUDE_DIR)/kernel.mk
@@ -33,7 +33,7 @@ define KernelPackage/ath10k-ct
FILES:=\
$(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_pci.ko \
$(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_core.ko
- AUTOLOAD:=$(call AutoProbe,mac80211 ath ath10k_pci)
+ AUTOLOAD:=$(call AutoProbe,ath10k_pci)
PROVIDES:=kmod-ath10k
endef