aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-25 18:02:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-25 18:02:51 +0000
commitb21c787bf688712277001db5778ae991b18c1a05 (patch)
tree1d58491c340844c1e9a2e5c8e4c47d11979a1bfb /package/iptables
parent99a2af66be8a17c0e1f491a9adcc34eeaf966b42 (diff)
downloadupstream-b21c787bf688712277001db5778ae991b18c1a05.tar.gz
upstream-b21c787bf688712277001db5778ae991b18c1a05.tar.bz2
upstream-b21c787bf688712277001db5778ae991b18c1a05.zip
iptables: libiptc.so is only a compatibility stub, split the package into libip4tc and libip6tc and adjust dependencies
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26292 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile35
1 files changed, 31 insertions, 4 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index fb740ef533..f0f96f0351 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -47,7 +47,7 @@ define Package/iptables
$(call Package/iptables/Default)
TITLE:=IPv4 firewall administration tool
MENU:=1
- DEPENDS+= +kmod-ipt-core +libiptc +libxtables
+ DEPENDS+= +kmod-ipt-core +libip4tc +libxtables
endef
define Package/iptables/description
@@ -237,7 +237,7 @@ endef
define Package/ip6tables
$(call Package/iptables/Default)
- DEPENDS:=+kmod-ip6tables +libiptc +libxtables
+ DEPENDS:=+kmod-ip6tables +libip6tc +libxtables
CATEGORY:=IPv6
TITLE:=IPv6 firewall administration tool
MENU:=1
@@ -254,7 +254,22 @@ define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
- TITLE:=IPv4/IPv6 firewall - shared libiptc library
+ DEPENDS:=+libip4tc +libip6tc
+ TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
+endef
+
+define Package/libip4tc
+$(call Package/iptables/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=IPv4 firewall - shared libiptc library
+endef
+
+define Package/libip6tc
+$(call Package/iptables/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=IPv6 firewall - shared libiptc library
endef
define Package/libxtables
@@ -352,7 +367,17 @@ endef
define Package/libiptc/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
+endef
+
+define Package/libip4tc/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip4tc.so* $(1)/usr/lib/
+endef
+
+define Package/libip6tc/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip6tc.so* $(1)/usr/lib/
endef
define Package/libxtables/install
@@ -402,5 +427,7 @@ $(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-utils))
$(eval $(call BuildPackage,libiptc))
+$(eval $(call BuildPackage,libip4tc))
+$(eval $(call BuildPackage,libip6tc))
$(eval $(call BuildPackage,libxtables))
$(eval $(call BuildPackage,libipq))