aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-06-07 15:30:59 +0000
committerTim Yardley <lst@openwrt.org>2007-06-07 15:30:59 +0000
commit35d1063a759bf86c75d05994e441dd8cd892660f (patch)
tree487aa7675ef2bfa3d6ba6d361c2347edf9cbc5bc /package/iptables
parentc43671dd28717d5f5cb72bdeda8d4204fc57b3bb (diff)
downloadupstream-35d1063a759bf86c75d05994e441dd8cd892660f.tar.gz
upstream-35d1063a759bf86c75d05994e441dd8cd892660f.tar.bz2
upstream-35d1063a759bf86c75d05994e441dd8cd892660f.zip
package ipset for use
SVN-Revision: 7517
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index bd85322ff3..bfd28a16aa 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -160,6 +160,14 @@ define Package/iptables-mod-extra
- libipt_NOTRACK
endef
+define Package/iptables-mod-ipset
+ $(call Package/iptables/Default)
+ DEPENDS:=iptables +kmod-ipt-ipset
+ TITLE:=ipset iptables extension
+ DESCRIPTION:=\
+ ipset
+endef
+
define Package/iptables-utils
$(call Package/iptables/Default)
DEPENDS:=iptables
@@ -263,6 +271,7 @@ $(eval $(call BuildPackage,iptables))
$(eval $(call BuildPackage,iptables-utils))
$(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
$(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
+$(eval $(call BuildPlugin,iptables-mod-ipset,$(IPT_IPSET-m)))
$(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
$(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
$(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))