aboutsummaryrefslogtreecommitdiffstats
path: root/package/iptables/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2008-08-04 11:51:58 +0000
committerJohn Crispin <blogic@openwrt.org>2008-08-04 11:51:58 +0000
commit275038cae7e3e363c1e0062d0639749178659a8b (patch)
tree366e67ab18afcef24dc1dfd1f5fb39eb7484275f /package/iptables/Makefile
parent8ffee3956dc468134bb14f47a7c82f248b9671ff (diff)
downloadupstream-275038cae7e3e363c1e0062d0639749178659a8b.tar.gz
upstream-275038cae7e3e363c1e0062d0639749178659a8b.tar.bz2
upstream-275038cae7e3e363c1e0062d0639749178659a8b.zip
adds a new uci firewall
- iptbales and netfilter packages need to be rewrapped when we switch to this firewall as default - there are some examples in the file /etc/config/firewall - iptables-save/restore are still missing - hotplug takes care of adding/removing netdevs during runtime - misisng features ? wishes ? let me know ... git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12089 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/iptables/Makefile')
-rw-r--r--package/iptables/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 05ef15b1dd..5b43dfefb7 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -58,11 +58,6 @@ $(call Package/iptables/Default)
MENU:=1
endef
-define Package/iptables/conffiles
-/etc/firewall.config
-/etc/firewall.user
-endef
-
define Package/iptables-mod-conntrack
$(call Package/iptables/Module, +kmod-ipt-conntrack)
TITLE:=connection tracking modules
@@ -247,13 +242,6 @@ define Build/InstallDev
endef
define Package/iptables/install
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_DATA) ./files/firewall.config $(1)/etc/
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
- $(INSTALL_BIN) ./files/firewall.user $(1)/etc/
- $(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_DATA) ./files/firewall.awk $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/lib/iptables