aboutsummaryrefslogtreecommitdiffstats
path: root/package/iproute2/patches/006-iproute2-tc_esfq.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-16 15:23:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-16 15:23:12 +0000
commit3f97b9eb36186f82a3b4efbb3bb6c3b35cb82388 (patch)
tree59213d3b456db06b6efa191c5928e7dae6b020a2 /package/iproute2/patches/006-iproute2-tc_esfq.patch
parentf9b64e59ca4b4373b2d3397f12c10da4aefc35b9 (diff)
downloadupstream-3f97b9eb36186f82a3b4efbb3bb6c3b35cb82388.tar.gz
upstream-3f97b9eb36186f82a3b4efbb3bb6c3b35cb82388.tar.bz2
upstream-3f97b9eb36186f82a3b4efbb3bb6c3b35cb82388.zip
iproute2: update to 3.3.0, drop a few useless old patches, add codel support
SVN-Revision: 31758
Diffstat (limited to 'package/iproute2/patches/006-iproute2-tc_esfq.patch')
-rw-r--r--package/iproute2/patches/006-iproute2-tc_esfq.patch79
1 files changed, 0 insertions, 79 deletions
diff --git a/package/iproute2/patches/006-iproute2-tc_esfq.patch b/package/iproute2/patches/006-iproute2-tc_esfq.patch
index 65dbc4f556..8016dbb962 100644
--- a/package/iproute2/patches/006-iproute2-tc_esfq.patch
+++ b/package/iproute2/patches/006-iproute2-tc_esfq.patch
@@ -4,85 +4,6 @@
tc/q_esfq.c | 200 ++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 260 insertions(+)
---- a/include/linux/pkt_sched.h
-+++ b/include/linux/pkt_sched.h
-@@ -174,8 +174,38 @@ struct tc_sfq_qopt
- *
- * The only reason for this is efficiency, it is possible
- * to change these parameters in compile time.
-+ *
-+ * If you need to play with these values use esfq instead.
- */
-
-+/* ESFQ section */
-+
-+enum
-+{
-+ /* traditional */
-+ TCA_SFQ_HASH_CLASSIC,
-+ TCA_SFQ_HASH_DST,
-+ TCA_SFQ_HASH_SRC,
-+ /* conntrack */
-+ TCA_SFQ_HASH_CTORIGDST,
-+ TCA_SFQ_HASH_CTORIGSRC,
-+ TCA_SFQ_HASH_CTREPLDST,
-+ TCA_SFQ_HASH_CTREPLSRC,
-+ TCA_SFQ_HASH_CTNATCHG,
-+};
-+
-+struct tc_esfq_qopt
-+{
-+ unsigned quantum; /* Bytes per round allocated to flow */
-+ int perturb_period; /* Period of hash perturbation */
-+ __u32 limit; /* Maximal packets in queue */
-+ unsigned divisor; /* Hash divisor */
-+ unsigned flows; /* Maximal number of flows */
-+ unsigned hash_kind; /* Hash function to use for flow identification */
-+};
-+
-+
-+
- /* RED section */
-
- enum
-@@ -579,8 +609,37 @@ struct tc_sfq_xstats {
- *
- * The only reason for this is efficiency, it is possible
- * to change these parameters in compile time.
-+ *
-+ * If you need to play with these values use esfq instead.
- */
-
-+/* ESFQ section */
-+
-+enum
-+{
-+ /* traditional */
-+ TCA_SFQ_HASH_CLASSIC,
-+ TCA_SFQ_HASH_DST,
-+ TCA_SFQ_HASH_SRC,
-+ /* conntrack */
-+ TCA_SFQ_HASH_CTORIGDST,
-+ TCA_SFQ_HASH_CTORIGSRC,
-+ TCA_SFQ_HASH_CTREPLDST,
-+ TCA_SFQ_HASH_CTREPLSRC,
-+ TCA_SFQ_HASH_CTNATCHG,
-+};
-+
-+struct tc_esfq_qopt
-+{
-+ unsigned quantum; /* Bytes per round allocated to flow */
-+ int perturb_period; /* Period of hash perturbation */
-+ __u32 limit; /* Maximal packets in queue */
-+ unsigned divisor; /* Hash divisor */
-+ unsigned flows; /* Maximal number of flows */
-+ unsigned hash_kind; /* Hash function to use for flow identification */
-+};
-+
-+
- /* RED section */
-
- enum {
--- a/tc/Makefile
+++ b/tc/Makefile
@@ -8,6 +8,7 @@ SHARED_LIBS ?= y