aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2011-06-13 13:16:11 +0000
committerMirko Vogt <mirko@openwrt.org>2011-06-13 13:16:11 +0000
commit471c8077ee2197f8365822ba359a7b74f8821e31 (patch)
treedf34387f4d44059b9b57ef639cc14e4f8ce7e28c /package/hotplug2
parent779bc3011982b1e1a4acd9927082d3925e971a41 (diff)
downloadupstream-471c8077ee2197f8365822ba359a7b74f8821e31.tar.gz
upstream-471c8077ee2197f8365822ba359a7b74f8821e31.tar.bz2
upstream-471c8077ee2197f8365822ba359a7b74f8821e31.zip
link hotplug2 against libbsd when eglibc is used
SVN-Revision: 27170
Diffstat (limited to 'package/hotplug2')
-rw-r--r--package/hotplug2/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 7e1dda7a04..9625ba27f9 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -28,6 +28,7 @@ define Package/hotplug2
VERSION:=1.0-beta-$(PKG_RELEASE)
TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+ DEPENDS:=+USE_EGLIBC:libbsd
endef
define Package/hotplug2/description
@@ -44,9 +45,13 @@ MAKE_FLAGS += \
COPTS="$(TARGET_CFLAGS)" \
STATIC_WORKER="fork"
+ifneq ($(CONFIG_USE_EGLIBC),)
+ TARGET_LDFLAGS += -lbsd
+endif
+
define Build/Compile
$(call Build/Compile/Default)
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
endef
define Package/hotplug2/install