aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-05-05 18:33:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-05-05 18:33:18 +0000
commitca7a8156029b94f9fe0e9d78a2502c0b0db98567 (patch)
treedbb58fde5a662952714b8c7221c94e9ea1c7e445 /package/hotplug2/Makefile
parent341b6afd554369bcd700dd505210955d521e9ee9 (diff)
downloadupstream-ca7a8156029b94f9fe0e9d78a2502c0b0db98567.tar.gz
upstream-ca7a8156029b94f9fe0e9d78a2502c0b0db98567.tar.bz2
upstream-ca7a8156029b94f9fe0e9d78a2502c0b0db98567.zip
use hotplug2 for serializing hotplug events on 2.6
SVN-Revision: 7097
Diffstat (limited to 'package/hotplug2/Makefile')
-rw-r--r--package/hotplug2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 6c2a0a1051..6b69bac733 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -21,7 +21,6 @@ include $(INCLUDE_DIR)/package.mk
define Package/hotplug2
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@LINUX_2_6 +udevtrigger
TITLE:=Dynamic device management subsystem for embedded systems
URL:=http://isteve.bofh.cz/~isteve/hotplug2/
endef
@@ -32,6 +31,9 @@ in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
endef
define Package/hotplug2/install
+ $(INSTALL_DIR) $(1)/etc
+ $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
+ $(INSTALL_DATA) ./files/hotplug2-init.rules $(1)/etc/
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
endef