aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2/Makefile
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2011-06-17 22:51:20 +0000
committerMirko Vogt <mirko@openwrt.org>2011-06-17 22:51:20 +0000
commit8d48672c109beb1a9cf515aea7c99c10af85f672 (patch)
tree60cb362802c7ad2d6ef91fdb57e820a583c348ed /package/hotplug2/Makefile
parent710409740e399196ed197d19c6217a8266d8d4e1 (diff)
downloadupstream-8d48672c109beb1a9cf515aea7c99c10af85f672.tar.gz
upstream-8d48672c109beb1a9cf515aea7c99c10af85f672.tar.bz2
upstream-8d48672c109beb1a9cf515aea7c99c10af85f672.zip
link against 'libbsd' when using glibc
SVN-Revision: 27209
Diffstat (limited to 'package/hotplug2/Makefile')
-rw-r--r--package/hotplug2/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 9625ba27f9..699976e8a9 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -28,7 +28,7 @@ define Package/hotplug2
VERSION:=1.0-beta-$(PKG_RELEASE)
TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
URL:=http://isteve.bofh.cz/~isteve/hotplug2/
- DEPENDS:=+USE_EGLIBC:libbsd
+ DEPENDS:=+USE_EGLIBC:libbsd +USE_GLIBC:libbsd
endef
define Package/hotplug2/description
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
COPTS="$(TARGET_CFLAGS)" \
STATIC_WORKER="fork"
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
TARGET_LDFLAGS += -lbsd
endif