aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-11 05:15:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-11 05:15:55 +0000
commit5501cf6ed82befd07a7249f51e8a71fd46654ddf (patch)
treeea52b798f1b44fd825a4a39c5256e39eab52de08 /package/hostapd
parent36eccaad210a4b1df56c7f5d8f5548170af19d1e (diff)
downloadupstream-5501cf6ed82befd07a7249f51e8a71fd46654ddf.tar.gz
upstream-5501cf6ed82befd07a7249f51e8a71fd46654ddf.tar.bz2
upstream-5501cf6ed82befd07a7249f51e8a71fd46654ddf.zip
hostapd: automatically add wds sta interfaces of an ap to the right bridge
SVN-Revision: 18365
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile2
-rw-r--r--package/hostapd/files/hostapd.hotplug12
2 files changed, 14 insertions, 0 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 606ec67360..a39b0e243c 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -109,6 +109,8 @@ define Build/Compile
endef
define Package/InstallTemplate
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/net
+ $(INSTALL_DATA) ./files/hostapd.hotplug $(1)/etc/hotplug.d/net/
$(INSTALL_DIR) $(1)/lib/wifi
$(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/wifi/hostapd.sh
$(INSTALL_DIR) $(1)/usr/sbin
diff --git a/package/hostapd/files/hostapd.hotplug b/package/hostapd/files/hostapd.hotplug
new file mode 100644
index 0000000000..2964224284
--- /dev/null
+++ b/package/hostapd/files/hostapd.hotplug
@@ -0,0 +1,12 @@
+if [ "$ACTION" = "add" -o "$ACTION" = "register" ]; then
+ case "$INTERFACE" in
+ wlan*.sta*)
+ local BASEIF="${INTERFACE%%\.*}"
+
+ include /lib/network
+ scan_interfaces
+ local CONFIG="$(find_config "$BASEIF")"
+ [ -n "$CONFIG" ] && setup_interface "$INTERFACE" "$CONFIG"
+ ;;
+ esac
+fi