aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-03-31 15:34:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-03-31 15:34:51 +0000
commit51670777c4ffa9af777a55bef1fd28b668aa655b (patch)
treef173bfe01f3d138e819435e2bfb1c6f6f8d4ce82 /package/hostapd/Makefile
parent00cb9df7b817384bb9751fe6acaab29f0dd6a404 (diff)
downloadupstream-51670777c4ffa9af777a55bef1fd28b668aa655b.tar.gz
upstream-51670777c4ffa9af777a55bef1fd28b668aa655b.tar.bz2
upstream-51670777c4ffa9af777a55bef1fd28b668aa655b.zip
hostapd: fix build error caused by r20631
SVN-Revision: 20638
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 38d91875eb..0ccba9ad99 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -25,6 +25,7 @@ PKG_BUILD_DEPENDS:= \
PKG_CONFIG_DEPENDS:= \
CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK \
CONFIG_PACKAGE_kmod-ath9k \
+ CONFIG_PACKAGE_kmod-rt2800-lib \
CONFIG_PACKAGE_kmod-mac80211 \
CONFIG_PACKAGE_kmod-madwifi \
CONFIG_PACKAGE_hostapd \
@@ -50,11 +51,19 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSI
include $(INCLUDE_DIR)/package.mk
+ifneq ($(CONFIG_PACKAGE_kmod-rt2800-lib),)
+ HOSTAPD_IEEE80211N:=y
+endif
+
+ifneq ($(CONFIG_PACKAGE_kmod-ath9k),)
+ HOSTAPD_IEEE80211N:=y
+endif
+
DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
- CONFIG_IEEE80211N=$(if ($(CONFIG_PACKAGE_kmod-ath9k)$(CONFIG_PACKAGE_kmod-rt2800-lib)),y) \
+ CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
ifneq ($(LOCAL_TYPE),hostapd)