aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-13 14:18:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-13 14:18:13 +0000
commit240b10673d5bb2b4fab34e6c4c5b8854fdfd6798 (patch)
tree764b2ac62c66bc0bb3436509b20c27ad8e45fa70 /package/hostapd/Makefile
parent383d17913fc5e2f2b2a25569a53258f437015cd3 (diff)
downloadupstream-240b10673d5bb2b4fab34e6c4c5b8854fdfd6798.tar.gz
upstream-240b10673d5bb2b4fab34e6c4c5b8854fdfd6798.tar.bz2
upstream-240b10673d5bb2b4fab34e6c4c5b8854fdfd6798.zip
make all wext wifi drivers select DRIVER_WEXT_SUPPORT, so that hostapd/wpa_supplicant can make it optional
SVN-Revision: 25518
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index b02ff27e72..3b4978fc86 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -31,7 +31,8 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_hostapd \
CONFIG_PACKAGE_hostapd-mini \
CONFIG_PACKAGE_kmod-hostap \
- CONFIG_WPA_RFKILL_SUPPORT
+ CONFIG_WPA_RFKILL_SUPPORT \
+ CONFIG_DRIVER_WEXT_SUPPORT
LOCAL_TYPE=$(strip \
$(if $(findstring wpad,$(BUILD_VARIANT)),wpad, \
@@ -66,6 +67,7 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
+ CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
$(if $(CONFIG_WPA_RFKILL_SUPPORT),NEED_RFKILL=y)
ifneq ($(LOCAL_TYPE),hostapd)