aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostap-driver/Makefile
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2007-11-28 03:44:18 +0000
committerTravis Kemen <thepeople@openwrt.org>2007-11-28 03:44:18 +0000
commitbe9bf2bf4093555b5ea30a4e6c4f19b761deeab2 (patch)
tree98abe0ad456fee802c2317a7ef431283d6f649ca /package/hostap-driver/Makefile
parentf30263eea0b36b97c97b8afb506fed52d7cfff3b (diff)
downloadupstream-be9bf2bf4093555b5ea30a4e6c4f19b761deeab2.tar.gz
upstream-be9bf2bf4093555b5ea30a4e6c4f19b761deeab2.tar.bz2
upstream-be9bf2bf4093555b5ea30a4e6c4f19b761deeab2.zip
add txpower patches and add uci configuration file From: Vasilis T. (aka Acinonyx)
SVN-Revision: 9610
Diffstat (limited to 'package/hostap-driver/Makefile')
-rw-r--r--package/hostap-driver/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/hostap-driver/Makefile b/package/hostap-driver/Makefile
index 5be9f9eb59..3a170f6b00 100644
--- a/package/hostap-driver/Makefile
+++ b/package/hostap-driver/Makefile
@@ -46,7 +46,7 @@ endef
define KernelPackage/hostap
$(call KernelPackage/hostap/Default)
TITLE:=Host AP support for Prism2/2.5/3
- DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211
+ DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211 +wireless-tools
KCONFIG:=CONFIG_HOSTAP
endef
@@ -174,6 +174,15 @@ else
endef
endif
+define KernelPackage/hostap-pci/install
+ $(INSTALL_DIR) $(1)/lib/wifi
+ $(INSTALL_DATA) ./files/lib/wifi/hostap.sh $(1)/lib/wifi
+endef
+
+define KernelPackage/hostap-plx/install
+ $(INSTALL_DIR) $(1)/lib/wifi
+ $(INSTALL_DATA) ./files/lib/wifi/hostap.sh $(1)/lib/wifi
+endef
$(eval $(call KernelPackage,hostap))
$(eval $(call KernelPackage,hostap-cs))