aboutsummaryrefslogtreecommitdiffstats
path: root/package/grub/Makefile
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-30 07:07:20 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-30 07:07:20 +0000
commit81f5f10a626bd5f9767fecef4ef73b80ab0216d9 (patch)
tree394bdf7cbd0f643ff5f00a1f3bf4b36bf39560e9 /package/grub/Makefile
parent5cd4a9739d948f626a8de7ea024d0f75b146be03 (diff)
downloadupstream-81f5f10a626bd5f9767fecef4ef73b80ab0216d9.tar.gz
upstream-81f5f10a626bd5f9767fecef4ef73b80ab0216d9.tar.bz2
upstream-81f5f10a626bd5f9767fecef4ef73b80ab0216d9.zip
package/grub: fix x86_64 issue (closes #7248)
SVN-Revision: 21264
Diffstat (limited to 'package/grub/Makefile')
-rw-r--r--package/grub/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 9a50f820ec..20232f4954 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -36,9 +36,12 @@ CONFIGURE_FLAGS:=
ifneq ($(HOST_OS),Darwin)
define Build/Configure
(cd $(PKG_BUILD_DIR); \
+ CFLAGS="-march=i486 -m32" \
LDFLAGS="-static" \
./configure \
$(CONFIGURE_FLAGS) \
+ --build=i386-linux-gnu \
+ --host=i386-linux-gnu \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \