aboutsummaryrefslogtreecommitdiffstats
path: root/package/gdb
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-09 14:11:33 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-09 14:11:33 +0000
commite80e75321fa78976317f414025233a386aa189d0 (patch)
treedaa1c728a0832bf63dcb4e0252207cf1859645b0 /package/gdb
parent2e94be02a8c7131d114009e9eb62c9948d931164 (diff)
downloadupstream-e80e75321fa78976317f414025233a386aa189d0.tar.gz
upstream-e80e75321fa78976317f414025233a386aa189d0.tar.bz2
upstream-e80e75321fa78976317f414025233a386aa189d0.zip
package/gdb: disable expat properly, remove conditional dependency on libexpat, bump release number
SVN-Revision: 28390
Diffstat (limited to 'package/gdb')
-rw-r--r--package/gdb/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/gdb/Makefile b/package/gdb/Makefile
index e3cd6860be..0c47a4c9e1 100644
--- a/package/gdb/Makefile
+++ b/package/gdb/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
PKG_VERSION:=6.8
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNU/gdb
@@ -29,7 +29,7 @@ endef
define Package/gdb
$(call Package/gdb/Default)
TITLE:=GNU Debugger
- DEPENDS+=+libreadline +libncurses +PACKAGE_libexpat:libexpat
+ DEPENDS+=+libreadline +libncurses
endef
define Package/gdb/description
@@ -51,7 +51,7 @@ endef
# XXX: add --disable-werror to prevent build failure with arm
CONFIGURE_ARGS+= \
--with-system-readline \
- --without-libexpat-prefix \
+ --without-expat \
--disable-werror
CONFIGURE_VARS+= \