aboutsummaryrefslogtreecommitdiffstats
path: root/package/gdb
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-01 09:32:01 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-01 09:32:01 +0000
commit7e5971a850fa418e22b3da97b7c8aafb8525df22 (patch)
tree4a7effaf21ef3f654c8d5c3d291fffc7bf7899db /package/gdb
parent2b36cc83f31e44e37d31ae61536bb0c7e678f403 (diff)
downloadupstream-7e5971a850fa418e22b3da97b7c8aafb8525df22.tar.gz
upstream-7e5971a850fa418e22b3da97b7c8aafb8525df22.tar.bz2
upstream-7e5971a850fa418e22b3da97b7c8aafb8525df22.zip
gdb: add dependency to libexpat when present
Also prevent gdb from trying to link against the host's libexpat. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27859 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/gdb')
-rw-r--r--package/gdb/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/gdb/Makefile b/package/gdb/Makefile
index 671340dddd..e3cd6860be 100644
--- a/package/gdb/Makefile
+++ b/package/gdb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
PKG_VERSION:=6.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNU/gdb
@@ -29,7 +29,7 @@ endef
define Package/gdb
$(call Package/gdb/Default)
TITLE:=GNU Debugger
- DEPENDS+=+libreadline +libncurses
+ DEPENDS+=+libreadline +libncurses +PACKAGE_libexpat:libexpat
endef
define Package/gdb/description
@@ -51,6 +51,7 @@ endef
# XXX: add --disable-werror to prevent build failure with arm
CONFIGURE_ARGS+= \
--with-system-readline \
+ --without-libexpat-prefix \
--disable-werror
CONFIGURE_VARS+= \