aboutsummaryrefslogtreecommitdiffstats
path: root/package/gdb
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-14 01:50:53 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-14 01:50:53 +0000
commit5a32f5677469d6cda8fcd1498a3456d44374a271 (patch)
tree34e21f587ef037396a02c931c92ab7cd8221614b /package/gdb
parentb6555735bd8bdb48c00d462ba0fc32a0bfb526f5 (diff)
downloadupstream-5a32f5677469d6cda8fcd1498a3456d44374a271.tar.gz
upstream-5a32f5677469d6cda8fcd1498a3456d44374a271.tar.bz2
upstream-5a32f5677469d6cda8fcd1498a3456d44374a271.zip
this patch fixes gdb parallel build.
-Raphael SVN-Revision: 20187
Diffstat (limited to 'package/gdb')
-rw-r--r--package/gdb/Makefile30
1 files changed, 18 insertions, 12 deletions
diff --git a/package/gdb/Makefile b/package/gdb/Makefile
index 6a166d0eb7..5044033a21 100644
--- a/package/gdb/Makefile
+++ b/package/gdb/Makefile
@@ -1,4 +1,5 @@
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
PKG_VERSION:=6.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNU/gdb
@@ -19,17 +20,19 @@ include $(INCLUDE_DIR)/package.mk
define Package/gdb/Default
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:= @!(avr32||cris)
+ DEPENDS:=@!(avr32||cris)
endef
define Package/gdb
$(call Package/gdb/Default)
TITLE:=GNU Debugger
- DEPENDS+= +libreadline +libncurses
+ DEPENDS+=+libreadline +libncurses
endef
define Package/gdb/description
- GNU debugger
+GDB, the GNU Project debugger, allows you to see what is going on `inside'
+another program while it executes -- or what another program was doing at the
+moment it crashed.
endef
define Package/gdbserver
@@ -38,14 +41,14 @@ $(call Package/gdb/Default)
endef
define Package/gdbserver/description
- GDBSERVER is a program that allows you to run GDB on a different machine
- than the one which is running the program being debugged.
+GDBSERVER is a program that allows you to run GDB on a different machine than the
+one which is running the program being debugged.
endef
# XXX: add --disable-werror to prevent build failure with arm
CONFIGURE_ARGS+= \
--with-system-readline \
- --disable-werror \
+ --disable-werror
CONFIGURE_VARS+= \
ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
@@ -54,19 +57,22 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
CPPFLAGS="$(TARGET_CPPFLAGS)" \
- all install-gdb
+ all
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ CPPFLAGS="$(TARGET_CPPFLAGS)" \
+ install-gdb
endef
-define Package/gdb/install
+define Package/gdb/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
endef
-define Package/gdbserver/install
+define Package/gdbserver/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
endef
$(eval $(call BuildPackage,gdb))
$(eval $(call BuildPackage,gdbserver))
-