aboutsummaryrefslogtreecommitdiffstats
path: root/package/fuse
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-28 09:17:29 +0000
commit1c4a2a55f76e481a2d1bc005405b9ce856d58939 (patch)
tree80dfa6ecb493ee8cb9ca1436f1b37ee89f320a55 /package/fuse
parentfdd5681c06468a606180f04c2533c8ba213a37f6 (diff)
downloadupstream-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.gz
upstream-1c4a2a55f76e481a2d1bc005405b9ce856d58939.tar.bz2
upstream-1c4a2a55f76e481a2d1bc005405b9ce856d58939.zip
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/fuse')
-rw-r--r--package/fuse/Config.in29
-rw-r--r--package/fuse/Makefile7
-rw-r--r--package/fuse/ipkg/kmod-fuse.control8
3 files changed, 2 insertions, 42 deletions
diff --git a/package/fuse/Config.in b/package/fuse/Config.in
index 92852bf1cb..5159140e3f 100644
--- a/package/fuse/Config.in
+++ b/package/fuse/Config.in
@@ -1,39 +1,14 @@
config BR2_PACKAGE_FUSE
bool
default n
- depends BR2_PACKAGE_KMOD_FUSE
+ depends BR2_PACKAGE_LIBFUSE
-config BR2_PACKAGE_KMOD_FUSE
- select BR2_PACKAGE_FUSE
- prompt "kmod-fuse - FUSE kernel module"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_FUSE
- help
- With FUSE it is possible to implement a fully functional
- filesystem in a userspace program.
-
- Features include:
-
- * Simple library API
- * Simple installation (no need to patch or recompile the kernel)
- * Secure implementation
- * Userspace - kernel interface is very efficient
- * Usable by non privileged users
- * Runs on Linux kernels 2.4.X and 2.6.X
- * Has proven very stable over time
-
-
- http://fuse.sourceforge.net/
-
- This package contains the fuse.o kernel module.
-
config BR2_PACKAGE_LIBFUSE
prompt "libfuse - FUSE library"
tristate
default m if CONFIG_DEVEL
- depends BR2_PACKAGE_KMOD_FUSE
+ select BR2_PACKAGE_KMOD_FUSE
select BR2_PACKAGE_LIBPTHREAD
help
With FUSE it is possible to implement a fully functional
diff --git a/package/fuse/Makefile b/package/fuse/Makefile
index 869689fe62..60fb4bec50 100644
--- a/package/fuse/Makefile
+++ b/package/fuse/Makefile
@@ -16,7 +16,6 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,KMOD_FUSE,kmod-fuse,$(LINUX_VERSION)+$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIBFUSE,libfuse,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,FUSE_UTILS,fuse-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -69,12 +68,6 @@ $(PKG_BUILD_DIR)/.built:
all install
touch $@
-$(IPKG_KMOD_FUSE):
- mkdir -p $(IDIR_KMOD_FUSE)/lib/modules/$(LINUX_VERSION)
- cp -fpR $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.o \
- $(IDIR_KMOD_FUSE)/lib/modules/$(LINUX_VERSION)/
- $(IPKG_BUILD) $(IDIR_KMOD_FUSE) $(PACKAGE_DIR)
-
$(IPKG_LIBFUSE):
mkdir -p $(IDIR_LIBFUSE)/usr/lib
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libfuse.so.* $(IDIR_LIBFUSE)/usr/lib/
diff --git a/package/fuse/ipkg/kmod-fuse.control b/package/fuse/ipkg/kmod-fuse.control
deleted file mode 100644
index 9d2e919c77..0000000000
--- a/package/fuse/ipkg/kmod-fuse.control
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: kmod-fuse
-Priority: optional
-Section: kernel
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/fuse2/
-Description: Filesystem in Userspace (kernel module)