aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2020-08-18 14:23:03 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-24 18:53:59 +0200
commited381e2fb2bde3e45295dff46f5fd8ca2e2c51b9 (patch)
tree6c9253c3f8c6a420872c7633ca8707aa6defcd39 /package/firmware
parent18aca6b17dd22791741645a84a9ca543ec2ef124 (diff)
downloadupstream-ed381e2fb2bde3e45295dff46f5fd8ca2e2c51b9.tar.gz
upstream-ed381e2fb2bde3e45295dff46f5fd8ca2e2c51b9.tar.bz2
upstream-ed381e2fb2bde3e45295dff46f5fd8ca2e2c51b9.zip
linux-firmware: add support for Marvell SDIO 8997
For example, Turris MOX SDIO card is using Marvell (NXP) 88W8997 chip. Technical specs of 88W8997: - 28nm - 802.11 ac wave-2 It should support simultaneous dual-band 2.4 GHz and 5 GHz, but it requires to support multiSSID for one Wi-Fi card [1], which is not supported in OpenWrt, yet and if we tried to run two instances of hostapd, it didn't work well, so it's 2.4 GHz or 5 GHz. - 2x2 MU-MIMO - Bluetooth 5.1 with LE support - Unfortunately, there can be connected only 8 clients at the same time (limited by FW, however, there exists "enterprise" chip, its equal chip, it is just different that it uses different FW) Symlink is necessary as mwifiex_sdio tries to load sd8997_uapsta.bin [ 13.651182] mwifiex_sdio mmc0:0001:1: Direct firmware load for mrvl/sd8997_uapsta.bin failed with error -2 [ 13.661065] mwifiex_sdio mmc0:0001:1: Falling back to user helper [ 13.684880] firmware mrvl!sd8997_uapsta.bin: firmware_loading_store: map pages failed [ 13.695910] mwifiex_sdio mmc0:0001:1: Failed to get firmware mrvl/sd8997_uapsta.bin [ 13.703774] mwifiex_sdio mmc0:0001:1: info: _mwifiex_fw_dpc: unregister device Pali Rohár sent two patches [2] [3] into kernel to fix default firmware name for SD8997, so the symlink will not be required in the future versions of kernel, which was accepted and right now, according to my details it was backported to 5.8, 5.7 and 5.4 [1] https://bugs.openwrt.org/index.php?do=details&task_id=3243 [2] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=00eb0cb36fad5 [3] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=2e1fcac52a9ea Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/Makefile2
-rw-r--r--package/firmware/linux-firmware/marvell.mk4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index ad3363ebd9..7dbcbdd8a3 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linux-firmware
PKG_VERSION:=20200817
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=@KERNEL/linux/kernel/firmware
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/package/firmware/linux-firmware/marvell.mk b/package/firmware/linux-firmware/marvell.mk
index 6c3f171216..78edac0ff3 100644
--- a/package/firmware/linux-firmware/marvell.mk
+++ b/package/firmware/linux-firmware/marvell.mk
@@ -20,12 +20,14 @@ define Package/mwifiex-pcie-firmware/install
endef
$(eval $(call BuildPackage,mwifiex-pcie-firmware))
-Package/mwifiex-sdio-firmware = $(call Package/firmware-default,Marvell 8887 firmware)
+Package/mwifiex-sdio-firmware = $(call Package/firmware-default,Marvell 8887/8997 firmware)
define Package/mwifiex-sdio-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/mrvl
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/mrvl/sd8887_uapsta.bin \
+ $(PKG_BUILD_DIR)/mrvl/sdsd8997_combo_v4.bin \
$(1)/lib/firmware/mrvl/
+ ln -s ../mrvl/sdsd8997_combo_v4.bin $(1)/lib/firmware/mrvl/sd8997_uapsta.bin
endef
$(eval $(call BuildPackage,mwifiex-sdio-firmware))