aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2019-08-30 07:27:51 +0200
committerJohn Crispin <john@phrozen.org>2019-08-30 07:27:51 +0200
commit63c722c0be399d08671033c134e615aa17365e88 (patch)
tree7eb7831ed7fc61c0051edb0321272826dfed7442 /package/firmware
parenta58bfb7377de2ccda55d66c78b0378d5d6ec7af9 (diff)
downloadupstream-63c722c0be399d08671033c134e615aa17365e88.tar.gz
upstream-63c722c0be399d08671033c134e615aa17365e88.tar.bz2
upstream-63c722c0be399d08671033c134e615aa17365e88.zip
linux-firmware: add mediatek BT firmware
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/mediatek.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/mediatek.mk b/package/firmware/linux-firmware/mediatek.mk
index b258551a00..18677bc748 100644
--- a/package/firmware/linux-firmware/mediatek.mk
+++ b/package/firmware/linux-firmware/mediatek.mk
@@ -41,3 +41,12 @@ define Package/rt73-usb-firmware/install
$(INSTALL_DATA) $(PKG_BUILD_DIR)/rt73.bin $(1)/lib/firmware/
endef
$(eval $(call BuildPackage,rt73-usb-firmware))
+
+Package/mt7622bt-firmware = $(call Package/firmware-default,mt7622bt firmware)
+define Package/mt7622bt-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/mediatek
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/mediatek/mt7622pr2h.bin \
+ $(1)/lib/firmware/mediatek
+endef
+$(eval $(call BuildPackage,mt7622bt-firmware))