aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-10-03 18:11:17 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-11-20 10:49:01 +0100
commit1bf1490eeb2fc9f3d067cb3bf82ef2f69cef1006 (patch)
tree045c7fd52e76694a4e1bf4aff23b5f3b62bdeede /package/firmware
parentc5d121654e74b74ca95df5efbca0db699ed07dbc (diff)
downloadupstream-1bf1490eeb2fc9f3d067cb3bf82ef2f69cef1006.tar.gz
upstream-1bf1490eeb2fc9f3d067cb3bf82ef2f69cef1006.tar.bz2
upstream-1bf1490eeb2fc9f3d067cb3bf82ef2f69cef1006.zip
am33x-cm3: remove
This is currently unused and not working anyway, since the used upstream kernel loads am335x-pm-firmware.elf and not am335x-pm-firmware.bin [0]. The last downstream patches using the latter were removed with e4eef7e6. Remove it instead of fixing it since the rtc-only sleep state can even damage the hardware [1]. [0] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ccbbb9faac946ce61c241ce9f08b3486fabf031d [1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7a6cb0abe1aa63334f3ded6d2b6c8eca80e72302 Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/am33x-cm3/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/package/firmware/am33x-cm3/Makefile b/package/firmware/am33x-cm3/Makefile
deleted file mode 100644
index e3923581bf..0000000000
--- a/package/firmware/am33x-cm3/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=am33x-cm3
-PKG_VERSION:=20130304
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=http://arago-project.org/git/projects/am33x-cm3.git
-PKG_SOURCE_VERSION:=32cf44e25b5828b87af6dceebc3a49fed5d858ac
-PKG_MIRROR_HASH:=71d4029eed4ef58a1e0beb299d5c876bf0b9a790ecac52aacf1d510f5841d959
-
-PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/am33x-cm3
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://arago-project.org/git/projects/?p=am33x-cm3.git
- TITLE:=TI AM335x PM firmware
- DEPENDS:=@TARGET_omap
-endef
-
-define Build/Compile
- $(MAKE) CROSS_COMPILE=$(TARGET_CROSS) -C $(PKG_BUILD_DIR)
-endef
-
-define Package/am33x-cm3/install
- $(INSTALL_DIR) $(1)/lib/firmware
- $(CP) $(PKG_BUILD_DIR)/bin/am335x-pm-firmware.bin $(1)/lib/firmware
-endef
-
-$(eval $(call BuildPackage,am33x-cm3))