aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-09-07 13:08:41 +0200
committerJohn Crispin <john@phrozen.org>2020-09-17 08:43:07 +0200
commit0fbdb51f7643db5fa4423333a68f34c6952dba24 (patch)
tree96fe7a46e272c8900730b539bc2355581e580155 /package/firmware
parent4488b260a02e169d6902df44debbe9b3c8e001cc (diff)
downloadupstream-0fbdb51f7643db5fa4423333a68f34c6952dba24.tar.gz
upstream-0fbdb51f7643db5fa4423333a68f34c6952dba24.tar.bz2
upstream-0fbdb51f7643db5fa4423333a68f34c6952dba24.zip
ipq40xx: add Edgecore OAP-100 support
flashing the unit * first update to latest edcore FW as per the PDF instructions * boot the initramfs - tftpboot 0x88000000 openwrt-ipq40xx-generic-edgecore_oap100-initramfs-fit-uImage.itb; bootm * inside the initramfs call the following commiands - ubiattach -p /dev/mtd0 - ubirmvol /dev/ubi0 -n0 - ubirmvol /dev/ubi0 -n1 - ubirmvol /dev/ubi0 -n2 * scp the sysupgrade image to the board and call - sysupgrade -n openwrt-ipq40xx-generic-edgecore_oap100-squashfs-nand-sysupgrade.bin Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ipq-wifi/Makefile2
-rw-r--r--package/firmware/ipq-wifi/board-edgecore_oap100.qca4019bin0 -> 24324 bytes
2 files changed, 2 insertions, 0 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index 963cf2d7c4..387b23d556 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -33,6 +33,7 @@ ALLWIFIBOARDS:= \
dlink_dap2610 \
edgecore_ecw5211 \
edgecore_ecw5410 \
+ edgecore_oap100 \
engenius_eap2200 \
engenius_emd1 \
engenius_emr3500 \
@@ -109,6 +110,7 @@ $(eval $(call generate-ipq-wifi-package,cellc_rtl30vw, Cell C RTL30VW))
$(eval $(call generate-ipq-wifi-package,dlink_dap2610,D-Link DAP-2610))
$(eval $(call generate-ipq-wifi-package,edgecore_ecw5211,Edgecore ECW5211))
$(eval $(call generate-ipq-wifi-package,edgecore_ecw5410,Edgecore ECW5410))
+$(eval $(call generate-ipq-wifi-package,edgecore_oap100,Edgecore OAP100))
$(eval $(call generate-ipq-wifi-package,engenius_eap2200,EnGenius EAP2200))
$(eval $(call generate-ipq-wifi-package,engenius_emd1,EnGenius EMD1))
$(eval $(call generate-ipq-wifi-package,engenius_emr3500,EnGenius EMR3500))
diff --git a/package/firmware/ipq-wifi/board-edgecore_oap100.qca4019 b/package/firmware/ipq-wifi/board-edgecore_oap100.qca4019
new file mode 100644
index 0000000000..9f1b5c93b5
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-edgecore_oap100.qca4019
Binary files differ