aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/vsc73x5-ucode
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-08 21:46:15 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-12 10:22:18 +0100
commit441ee62931140bd0672dd87e084a3606962db45c (patch)
tree0b9bc3fc2eea3eadc13eed9b9d608616b22ec5d3 /package/firmware/vsc73x5-ucode
parentfa04682f213f81840ca17022ca5aa9439bc22f2c (diff)
downloadupstream-441ee62931140bd0672dd87e084a3606962db45c.tar.gz
upstream-441ee62931140bd0672dd87e084a3606962db45c.tar.bz2
upstream-441ee62931140bd0672dd87e084a3606962db45c.zip
ar71xx: remove AP83 reference design board support
This board is very old and unlikely to still be relevant today. Support for it contains a significant amount of device specific baggage which is worth getting rid of. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/firmware/vsc73x5-ucode')
-rw-r--r--package/firmware/vsc73x5-ucode/Makefile30
1 files changed, 1 insertions, 29 deletions
diff --git a/package/firmware/vsc73x5-ucode/Makefile b/package/firmware/vsc73x5-ucode/Makefile
index e3379a1f95..d73053bc17 100644
--- a/package/firmware/vsc73x5-ucode/Makefile
+++ b/package/firmware/vsc73x5-ucode/Makefile
@@ -34,32 +34,6 @@ define Package/vsc73x5/install
$(INSTALL_DATA) $(PKG_BUILD_DIR)/$(2) $(1)/lib/firmware/$(3)
endef
-define Package/vsc7385-ucode-ap83
- $(call Package/vsc73x5-defaults,Vitesse VSC7385 microcode for the Atheros AP83 boards)
-endef
-
-define Package/vsc7385-ucode-ap83/description
- This package contains the Atheros AP83 board specific microcode for
- the Vitesse VSC7385 ethernet switch.
-endef
-
-define Package/vsc7385-ucode-ap83/install
- $(call Package/vsc73x5/install,$(1),g5_Plus1_2_31_unmanaged_Atheros_v3.bin,vsc7385_ucode_ap83.bin)
-endef
-
-define Package/vsc7395-ucode-ap83
- $(call Package/vsc73x5-defaults, Vitesse VSC7395 microcode for the Atheros AP83 boards)
-endef
-
-define Package/vsc7395-ucode-ap83/description
- This package contains the Atheros AP83 board specific microcode for
- the Vitesse VSC7395 ethernet switch.
-endef
-
-define Package/vsc7395-ucode-ap83/install
- $(call Package/vsc73x5/install,$(1),g5_Plus1_2_31_unmanaged_Atheros_v4.bin,vsc7395_ucode_ap83.bin)
-endef
-
define Package/vsc7385-ucode-pb44
$(call Package/vsc73x5-defaults, Vitesse VSC7395 microcode for the Atheros PB44 boards)
endef
@@ -78,7 +52,7 @@ define Package/vsc7395-ucode-pb44
endef
define Package/vsc7395-ucode-pb44/description
- This package contains the Atheros AP83 board specific microcode for
+ This package contains the Atheros PB44 board specific microcode for
the Vitesse VSC7395 ethernet switch.
endef
@@ -90,7 +64,5 @@ define Build/Compile
endef
-$(eval $(call BuildPackage,vsc7385-ucode-ap83))
-$(eval $(call BuildPackage,vsc7395-ucode-ap83))
$(eval $(call BuildPackage,vsc7385-ucode-pb44))
$(eval $(call BuildPackage,vsc7395-ucode-pb44))