aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/vsc73x5-ucode/files
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-30 09:15:25 +0000
committerJohn Crispin <john@openwrt.org>2014-03-30 09:15:25 +0000
commit4001a1ee153d1727adafc24e1e65fae6ccdded3d (patch)
tree52212ddf7cfc4eb34ac10d1e1215b5e695f1587c /package/firmware/vsc73x5-ucode/files
parentbc03add2731202dfa428e8da61ed9bb4aa0ae8e5 (diff)
downloadupstream-4001a1ee153d1727adafc24e1e65fae6ccdded3d.tar.gz
upstream-4001a1ee153d1727adafc24e1e65fae6ccdded3d.tar.bz2
upstream-4001a1ee153d1727adafc24e1e65fae6ccdded3d.zip
firmware: create a new folder for holfing firmware blobs
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 40307
Diffstat (limited to 'package/firmware/vsc73x5-ucode/files')
-rw-r--r--package/firmware/vsc73x5-ucode/files/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/firmware/vsc73x5-ucode/files/Makefile b/package/firmware/vsc73x5-ucode/files/Makefile
new file mode 100644
index 0000000000..550f51df79
--- /dev/null
+++ b/package/firmware/vsc73x5-ucode/files/Makefile
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+CC:=gcc
+OBJCOPY:=objcopy
+
+all: g5_Plus1_2_31_unmanaged_Atheros_v3.bin \
+ g5_Plus1_2_31_unmanaged_Atheros_v4.bin \
+ g5_Plus1_2_29b_unmanaged_Atheros_v5.bin \
+ g5e_Plus1_2_29a_unmanaged_Atheros_v3.bin
+
+%.o: %.c
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+%.bin: %.o
+ $(OBJCOPY) -O binary -j .data $^ $@