aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/linux-firmware
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-11-12 14:52:29 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-11-22 22:37:05 +0100
commit9cfcd497358545781e5c0e3ee169894d1d3329a8 (patch)
treeb308c2b01ea0760d8234f3d5ed1f06a98c10cca3 /package/firmware/linux-firmware
parent06e1b90404cbad66d02aef66d81b46bd771f099c (diff)
downloadupstream-9cfcd497358545781e5c0e3ee169894d1d3329a8.tar.gz
upstream-9cfcd497358545781e5c0e3ee169894d1d3329a8.tar.bz2
upstream-9cfcd497358545781e5c0e3ee169894d1d3329a8.zip
kernel: e100: take e100 firmware from linux-firmware repository
The firmware directory in the Linux kernel was removed in kernel 4.14, take the e100 firmware files now from the linux-firmware repository instead. To do so create the new package e100-firmware. This will also work with older kernel versions. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/firmware/linux-firmware')
-rw-r--r--package/firmware/linux-firmware/intel.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/firmware/linux-firmware/intel.mk b/package/firmware/linux-firmware/intel.mk
index 0330335bfb..8cdbb48245 100644
--- a/package/firmware/linux-firmware/intel.mk
+++ b/package/firmware/linux-firmware/intel.mk
@@ -153,3 +153,12 @@ define Package/iwlwifi-firmware-iwl8265/install
$(INSTALL_DATA) $(PKG_BUILD_DIR)/iwlwifi-8265-27.ucode $(1)/lib/firmware
endef
$(eval $(call BuildPackage,iwlwifi-firmware-iwl8265))
+
+Package/e100-firmware = $(call Package/firmware-default,Intel e100)
+define Package/e100-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/e100
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/e100/d101m_ucode.bin $(1)/lib/firmware/e100/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/e100/d101s_ucode.bin $(1)/lib/firmware/e100/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/e100/d102e_ucode.bin $(1)/lib/firmware/e100/
+endef
+$(eval $(call BuildPackage,e100-firmware))