aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/layerscape
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-10 11:58:59 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:57 +0200
commitf0ec7bd27d206ea0eb9587e178ce0d7ddc006bce (patch)
treee5a732d69a332010950f3f800838c8a14390a60c /package/firmware/layerscape
parent0d95eb2cce62102a849e8c9552c30dfee3fe6189 (diff)
downloadupstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.tar.gz
upstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.tar.bz2
upstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.zip
layerscape: add armv7 subtarget and ls1021atwr board support
The NXP TWR-LS1021A module is a development system based on the QorIQ LS1021A processor. - This feature-rich, high-performance processor module can be used standalone or as part of an assembled Tower System development platform. - Incorporating dual Arm Cortex-A7 cores running up to 1 GHz, the TWR-LS1021A delivers an outstanding level of performance. - The TWR-LS1021A offers HDMI, SATA3 and USB3 connectors as well as a complete Linux software developer's package. - The module provides a comprehensive level of security that includes support for secure boot, Trust Architecture and tamper detection in both standby and active power modes, safeguarding the device from manufacture to deployment. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/firmware/layerscape')
-rw-r--r--package/firmware/layerscape/ls-rcw/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/firmware/layerscape/ls-rcw/Makefile b/package/firmware/layerscape/ls-rcw/Makefile
index 8d873baf08..d12bff9bba 100644
--- a/package/firmware/layerscape/ls-rcw/Makefile
+++ b/package/firmware/layerscape/ls-rcw/Makefile
@@ -58,6 +58,11 @@ define Package/layerscape-rcw/ls2088ardb
CONFIG:=ls2088ardb/FFFFFFFF_PP_HH_0x2a_0x41/rcw_1800.bin
endef
+define Package/layerscape-rcw/ls1021atwr
+ TITLE:=NXP LS1021ATWR RCW binary
+ CONFIG:=ls1021atwr/SSR_PNS_30/rcw_1200.bin
+endef
+
define Package/layerscape-rcw/Install
define Package/layerscape-rcw-$(1)/install
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
@@ -71,7 +76,8 @@ RCWS := \
ls1043ardb \
ls1046ardb \
ls1088ardb \
- ls2088ardb
+ ls2088ardb \
+ ls1021atwr
$(foreach rcw,$(RCWS), \
$(eval $(Package/layerscape-rcw/$(rcw))) \