aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/layerscape
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-18 16:56:07 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:57 +0200
commit7016dd48f164364e1ee7b9d86169375691f7be0d (patch)
treea8bb408214ca6cbb8cb7b764d79803488310a72e /package/firmware/layerscape
parenteb684205e5e6958ad71cf4a179fa776f6507f7e3 (diff)
downloadupstream-7016dd48f164364e1ee7b9d86169375691f7be0d.tar.gz
upstream-7016dd48f164364e1ee7b9d86169375691f7be0d.tar.bz2
upstream-7016dd48f164364e1ee7b9d86169375691f7be0d.zip
layerscape: add ls1012afrwy support and drop ls1012afrdm
ls1012afrdm was no longer supported in NXP Layerscape SDK. Instead a new board ls1012afrwy was introduced in LSDK. This patch is to drop ls1012afrdm and add ls1012afrwy support. Since only 2MB NOR flash could be used, we just put u-boot and firmware on NOR flash, and put kernel/dtb/rootfs on SD card. The Layerscape FRWY-LS1012A board is an ultra-low-cost development platform for LS1012A Series Communication Processors built on Arm Cortex-A53. This tool refines the FRDM-LS1012A with more features for a better hands-on experience for IoT, edge computing, and various advanced embedded applications. Features include easy access to processor I/O, low-power operation, micro SD card storage, an M2 connector, a small form factor, and expansion board options via mikroBUS Click Module. The MicroBUS Module provides easy expansion via hundreds of powerful modules supporting sensors, actuators, memories, and displays. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/firmware/layerscape')
-rw-r--r--package/firmware/layerscape/ls-ppa/Makefile6
-rw-r--r--package/firmware/layerscape/ls-rcw/Makefile8
2 files changed, 7 insertions, 7 deletions
diff --git a/package/firmware/layerscape/ls-ppa/Makefile b/package/firmware/layerscape/ls-ppa/Makefile
index 7a6a9b0b84..159f5ef6d4 100644
--- a/package/firmware/layerscape/ls-ppa/Makefile
+++ b/package/firmware/layerscape/ls-ppa/Makefile
@@ -33,8 +33,8 @@ define Package/layerscape-ppa/ls1012ardb
CONFIG:=ppa-ls1012a.itb
endef
-define Package/layerscape-ppa/ls1012afrdm
- TITLE:=NXP LS1012AFRDM PPA binary
+define Package/layerscape-ppa/ls1012afrwy
+ TITLE:=NXP LS1012AFRWY PPA binary
CONFIG:=ppa-ls1012a.itb
endef
@@ -70,7 +70,7 @@ endef
PPAS := \
ls1012ardb \
- ls1012afrdm \
+ ls1012afrwy \
ls1043ardb \
ls1046ardb \
ls1088ardb \
diff --git a/package/firmware/layerscape/ls-rcw/Makefile b/package/firmware/layerscape/ls-rcw/Makefile
index 13d015d251..9de68b1cc9 100644
--- a/package/firmware/layerscape/ls-rcw/Makefile
+++ b/package/firmware/layerscape/ls-rcw/Makefile
@@ -33,9 +33,9 @@ define Package/layerscape-rcw/ls1012ardb
CONFIG:=ls1012ardb/R_SPNH_3508/rcw_1000_default.bin.swapped
endef
-define Package/layerscape-rcw/ls1012afrdm
- TITLE:=NXP LS1012AFRDM RCW binary
- CONFIG:=ls1012afrdm/N_SSNP_3305/rcw_800.bin.swapped
+define Package/layerscape-rcw/ls1012afrwy
+ TITLE:=NXP LS1012AFRWY RCW binary
+ CONFIG:=ls1012afrwy/N_SSNP_3305/rcw_1000_default.bin.swapped
endef
define Package/layerscape-rcw/ls1043ardb
@@ -77,7 +77,7 @@ endef
RCWS := \
ls1012ardb \
- ls1012afrdm \
+ ls1012afrwy \
ls1043ardb \
ls1046ardb \
ls1088ardb \