aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/layerscape
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-10-24 18:07:38 +0800
committerJohn Crispin <john@phrozen.org>2017-11-10 23:00:49 +0100
commit2b1ec44dbd3cd3419231bb88bf9881333ae445c5 (patch)
treef156c44c0374d34d6778448416abe13799b75f27 /package/firmware/layerscape
parent9e7b1667046201b2d52108d6c8769bebd4f6736c (diff)
downloadupstream-2b1ec44dbd3cd3419231bb88bf9881333ae445c5.tar.gz
upstream-2b1ec44dbd3cd3419231bb88bf9881333ae445c5.tar.bz2
upstream-2b1ec44dbd3cd3419231bb88bf9881333ae445c5.zip
layerscape: add ls1012afrdm device support
The QorIQ FRDM-LS1012A Board is an ultra-low-cost development platform for QorIQ LS1012A Series Network Processors built on ARM Cortex-A53 processor. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/firmware/layerscape')
-rw-r--r--package/firmware/layerscape/ppa/Makefile8
-rw-r--r--package/firmware/layerscape/rcw/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/package/firmware/layerscape/ppa/Makefile b/package/firmware/layerscape/ppa/Makefile
index eea8c5fdd2..c72439ade4 100644
--- a/package/firmware/layerscape/ppa/Makefile
+++ b/package/firmware/layerscape/ppa/Makefile
@@ -53,12 +53,18 @@ define ppa/ls2088ardb
CONFIG=ppa-ls2088a.itb
endef
+define ppa/ls1012afrdm
+ TITLE=PPA firmware $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012afrdm 64b/32b Dev Board
+ CONFIG=ppa-ls1012a.itb
+endef
+
PPAS := \
ls1043ardb \
ls1046ardb \
ls1012ardb \
ls1088ardb \
- ls2088ardb
+ ls2088ardb \
+ ls1012afrdm
define Package/ppa/template
define Package/layerscape-ppa-$(1)
diff --git a/package/firmware/layerscape/rcw/Makefile b/package/firmware/layerscape/rcw/Makefile
index c638f97b13..f4d9eebc89 100644
--- a/package/firmware/layerscape/rcw/Makefile
+++ b/package/firmware/layerscape/rcw/Makefile
@@ -56,12 +56,18 @@ define rcw/ls2088ardb
CONFIG=ls2088ardb/FFFFFFFF_PP_HH_0x2a_0x41/PBL_0x2a_0x41_1800_700_1866_1600.bin
endef
+define rcw/ls1012afrdm
+ TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012afrdm 64b/32b Dev Board
+ CONFIG=ls1012afrdm/N_SSNP_3305/PBL_0x33_0x05_800_250_1000_default.bin
+endef
+
RCWS := \
ls1043ardb \
ls1046ardb \
ls1012ardb \
ls1088ardb \
- ls2088ardb
+ ls2088ardb \
+ ls1012afrdm
define Package/rcw/template
define Package/rcw-layerscape-$(1)