aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/layerscape/ls-mc/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-12-21 09:32:51 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-21 10:02:16 +0100
commitdda2229c52c78d177a417e261d3dd912f65101fe (patch)
treeb5ee53da2b4bb939887b40af1f9d3df2cfeabdb2 /package/firmware/layerscape/ls-mc/Makefile
parente90dc8d27221bf00daa7c49a986cc0bac6f2e070 (diff)
downloadupstream-dda2229c52c78d177a417e261d3dd912f65101fe.tar.gz
upstream-dda2229c52c78d177a417e261d3dd912f65101fe.tar.bz2
upstream-dda2229c52c78d177a417e261d3dd912f65101fe.zip
layerscape: fix package download
The git hash was changed for multiple layerscape packages without changing the version number. The LEDE build system will not download the packages again if the old version is already there and so some people and the build bots are using wrong version of some packages. Use PKG_SOURCE_DATE instead of PKG_VERSION to generate packages with the date and the first charterers of the git hash. This will change the file name and make the build system download them again, also if in future the git hash is changed the file name will change and trigger a new download. This should fix a problem spotted by build bot. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/firmware/layerscape/ls-mc/Makefile')
-rw-r--r--package/firmware/layerscape/ls-mc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/firmware/layerscape/ls-mc/Makefile b/package/firmware/layerscape/ls-mc/Makefile
index 377ac0a3d1..eb58dd70a4 100644
--- a/package/firmware/layerscape/ls-mc/Makefile
+++ b/package/firmware/layerscape/ls-mc/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ls-mc
-PKG_VERSION:=2017.09
+PKG_SOURCE_DATE:=2014-07-04
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/qoriq-open-source/mc-binary.git
PKG_SOURCE_VERSION:=824745fe1580b281bebb808321c3f41353a3140a
-PKG_MIRROR_HASH:=9c8e154cf070b2ddd1198646ae9c6a7fc148a241b4b1d49f6c6f16aa01b67f16
+PKG_MIRROR_HASH:=984c7905af3a4b87b72263de9220901c531fe064f0b89dd2882676354e09ed16
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)