aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/layerscape/fman-ucode
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-20 15:34:04 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-27 12:06:52 +0200
commit0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300 (patch)
tree26b4069abaffe012b329d8a96b37ea9aac863c1d /package/firmware/layerscape/fman-ucode
parenta1eb2c463352d05161a756f806e8e8a039f4490c (diff)
downloadupstream-0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300.tar.gz
upstream-0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300.tar.bz2
upstream-0f3c3a5fb2738b25c62eb0ff8ef7d0654c0b9300.zip
layerscape: harmonize device strings
OpenWrt lately has harmonized device (definition) names to the pattern vendor_model to improve overall consistency, also with other values like the DTS compatible. This patch applies that scheme to the layerscape target. Since this (intentionally) creates a bigger overlap between DTS names, compatible, and device definition name, it also moves DEVICE_DTS and SUPPORTED_DEVICES definitions to the Device/Default blocks. Apart from that, it also modifies several packages to use consistent naming in order to keep the $(1) file references working. While at it, remove one layer of complexity for the setup in tfa-layerscape package. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/firmware/layerscape/fman-ucode')
-rw-r--r--package/firmware/layerscape/fman-ucode/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/firmware/layerscape/fman-ucode/Makefile b/package/firmware/layerscape/fman-ucode/Makefile
index ba1dcf9160..8c76774ac7 100644
--- a/package/firmware/layerscape/fman-ucode/Makefile
+++ b/package/firmware/layerscape/fman-ucode/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=fman-ucode
PKG_VERSION:=LSDK-20.04
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/NXP/qoriq-fm-ucode.git
@@ -31,9 +31,9 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/fsl_fman_ucode_ls1043_r1.1_106_4_18.bin \
- $(STAGING_DIR_IMAGE)/ls1043ardb-fman.bin
+ $(STAGING_DIR_IMAGE)/fsl_ls1043a-rdb-fman.bin
$(CP) $(PKG_BUILD_DIR)/fsl_fman_ucode_ls1046_r1.0_106_4_18.bin \
- $(STAGING_DIR_IMAGE)/ls1046ardb-fman.bin
+ $(STAGING_DIR_IMAGE)/fsl_ls1046a-rdb-fman.bin
endef
$(eval $(call BuildPackage,layerscape-fman))