aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/lantiq/dsl-vrx200-firmware-xdsl-a
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-03-07 11:03:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-03-07 11:03:09 +0000
commit8b41bb6648447dfcde7a26430769dd85005121fd (patch)
treec6456c13dc4eec5979daf70e594b13571fb6a320 /package/firmware/lantiq/dsl-vrx200-firmware-xdsl-a
parent2cfd943fe9074c3bfd1c293222d7de381e2f1576 (diff)
downloadupstream-8b41bb6648447dfcde7a26430769dd85005121fd.tar.gz
upstream-8b41bb6648447dfcde7a26430769dd85005121fd.tar.bz2
upstream-8b41bb6648447dfcde7a26430769dd85005121fd.zip
dsl-vrx200-firmware-xdsl: create Lantiq vrx200 firmware patches
Instead of having two big binaries only add one binary and then a patch to create the other one when needed at runtime. This is easier to handle in one Makefile for both firmware files. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48939
Diffstat (limited to 'package/firmware/lantiq/dsl-vrx200-firmware-xdsl-a')
-rw-r--r--package/firmware/lantiq/dsl-vrx200-firmware-xdsl-a/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/package/firmware/lantiq/dsl-vrx200-firmware-xdsl-a/Makefile b/package/firmware/lantiq/dsl-vrx200-firmware-xdsl-a/Makefile
deleted file mode 100644
index e8dd6599a3..0000000000
--- a/package/firmware/lantiq/dsl-vrx200-firmware-xdsl-a/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright (C) 2015 OpenWrt.org
-# Copyright (C) 2015 Lantiq Beteiligungs GmbH & Co KG.
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=dsl_vr9_firmware_xdsl
-PKG_VERSION:=05.07.04.03.00.06_05.07.01.08.00.01_osc
-PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
-PKG_MD5SUM:=4c8d9ca68dda88d3cfc0ca0fb946a63e
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/dsl-vrx200-firmware-xdsl-a
- SECTION:=firmware
- CATEGORY:=Firmware
- TITLE:=VRX200 / VR9 CPE xDSL Annex A firmware
- URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_xrx200
-endef
-
-define Package/dsl-vrx200-firmware-xdsl-a/description
- VRX200 / VR9 CPE VDSL and ADSL Annex A firmware
-endef
-
-define Build/Prepare
- rm -rf $(PKG_BUILD_DIR)
- mkdir -p $(PKG_BUILD_DIR)
- $(TAR) -C $(PKG_BUILD_DIR) -xzf $(DL_DIR)/$(PKG_SOURCE)
-endef
-
-define Build/Compile
-endef
-
-define Package/dsl-vrx200-firmware-xdsl-a/install
- $(INSTALL_DIR) $(1)/lib/firmware/
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/LICENSE $(1)/lib/firmware/xcpe_574306_571801.LICENSE
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/xcpe_574306_571801.bin $(1)/lib/firmware/
- ln -s xcpe_574306_571801.bin $(1)/lib/firmware/vdsl.bin
- ln -s xcpe_574306_571801.bin $(1)/lib/firmware/adsl-a.bin
-endef
-
-$(eval $(call BuildPackage,dsl-vrx200-firmware-xdsl-a))