aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ipq-wifi
diff options
context:
space:
mode:
authorMarius Genheimer <mail@f0wl.cc>2019-02-12 17:19:51 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-02-14 16:56:15 +0100
commit9ad3967f140bd6d08796f1ec151b753186b3eb44 (patch)
treeb1931a6545b3f2f6d549066ab1d4dc145d44a56e /package/firmware/ipq-wifi
parent5ee9763aaab92757846a7b3d3f6e26812e3a42f3 (diff)
downloadupstream-9ad3967f140bd6d08796f1ec151b753186b3eb44.tar.gz
upstream-9ad3967f140bd6d08796f1ec151b753186b3eb44.tar.bz2
upstream-9ad3967f140bd6d08796f1ec151b753186b3eb44.zip
ipq40xx: add support for ASUS Lyra
SoC: Qualcomm IPQ4019 (Dakota) 717 MHz, 4 cores RAM: 256 MiB (Nanya NT5CC128M16IP-DI) FLASH: 128 MiB (Macronix NAND) WiFi0: Qualcomm IPQ4019 b/g/n 2x2 WiFi1: Qualcomm IPQ4019 a/n/ac 2x2 WiFi2: Qualcomm Atheros QCA9886 a/n/ac BT: Atheros AR3012 IN: WPS Button, Reset Button OUT: RGB-LED via TI LP5523 9-channel Controller UART: Front of Device - 115200 N-8 Pinout 3.3v - RX - TX - GND (Square is VCC) Installation: 1. Transfer OpenWRT-initramfs image to the device via SSH to /tmp. Login credentials are identical to the Web UI. 2. Login to the device via SSH. 3. Flash the initramfs image using > mtd-write -d linux -i openwrt-image-file 4. Power-cycle the device and wait for OpenWRT to boot. 5. From there flash the OpenWRT-sysupgrade image. Ethernet-Ports: Although labeled identically, the port next to the power socket is the LAN port and the other one is WAN. This is the same behavior as in the stock firmware. Signed-off-by: Marius Genheimer <mail@f0wl.cc> [Dropped setup_mac 02_network in favour of 05_set_iface_mac_ipq40xx.sh, reorderd 02_network entries, added board.bin WA for the QCA9886 from ath79, minor dts touchup, added rng to 4.19 dts] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/firmware/ipq-wifi')
-rw-r--r--package/firmware/ipq-wifi/Makefile3
-rw-r--r--package/firmware/ipq-wifi/board-map-ac2200.binbin0 -> 24324 bytes
2 files changed, 2 insertions, 1 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index cf1ad042bf..7c9def8967 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -17,7 +17,7 @@ endef
# Please send a mail with your device-specific board files upstream.
# You can find instructions and examples on the linux-wireless wiki:
# <https://wireless.wiki.kernel.org/en/users/drivers/ath10k/boardfiles>
-ALLWIFIBOARDS:=engenius_eap1300 linksys_ea6350v3
+ALLWIFIBOARDS:=asus_map-ac2200 engenius_eap1300 linksys_ea6350v3
ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
define Package/ipq-wifi-default
@@ -52,6 +52,7 @@ Don't install it for any other device!
endef
#$(eval $(call generate-ipq-wifi-package,<devicename>,<filename>,<displayname>))
+$(eval $(call generate-ipq-wifi-package,asus_map-ac2200,board-map-ac2200.bin,ASUS MAP-AC2200))
$(eval $(call generate-ipq-wifi-package,engenius_eap1300,board-engenius_eap1300.bin,EnGenius EAP1300))
$(eval $(call generate-ipq-wifi-package,linksys_ea6350v3,board-linksys_ea6350v3.bin,Linksys EA6350v3))
diff --git a/package/firmware/ipq-wifi/board-map-ac2200.bin b/package/firmware/ipq-wifi/board-map-ac2200.bin
new file mode 100644
index 0000000000..372936010a
--- /dev/null
+++ b/package/firmware/ipq-wifi/board-map-ac2200.bin
Binary files differ