aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ipq-wifi/Makefile
diff options
context:
space:
mode:
authorDongming Han <handongming@gl-inet.com>2017-12-07 20:48:19 +0800
committerJohn Crispin <john@phrozen.org>2018-02-14 09:40:32 +0100
commit04d3308b6248ef21a6f0bc3378b342906c2d2865 (patch)
tree9180681b935ec6494df250411112327f07e9ef9f /package/firmware/ipq-wifi/Makefile
parent88a41074e8e7012c2cb73b85263425c4c474beb1 (diff)
downloadupstream-04d3308b6248ef21a6f0bc3378b342906c2d2865.tar.gz
upstream-04d3308b6248ef21a6f0bc3378b342906c2d2865.tar.bz2
upstream-04d3308b6248ef21a6f0bc3378b342906c2d2865.zip
ipq806x: add support for GL.iNet GL-B1300
This patch adds support for GL.iNet GL-B1300 Specification: - SOC: IPQ4028 / QCA Dakota - RAM: 256 MiB - FLASH: 32 MiB - ETH: Qualcomm Atheros QCA8075 Gigabit Switch (2 x LAN, 1 x WAN) - USB: 1 x 3.0 (via Synopsys DesignWare DWC3 controller in the SoC) - WLAN1: Qualcomm Atheros QCA4028 2.4GHz 802.11bgn 2:2x2 - WLAN2: Qualcomm Atheros QCA4028 5GHz 802.11a/n/ac 2:2x2 - INPUT: one reset and one WPS button - LEDS: 3 leds: Power, WIFI(only for 2.4G currently), and one reserved - UART: 1 x UART on PCB (3.3V, TX, RX, GND) - 115200 8N1 Installation: Method 1: - use serial port to stop uboot - uboot command: run lf Method 2: - push down reset button and power on - wait until three leds constantly on then release - upgrade by uboot web at http://192.168.1.1 Note: - the sysupgrade image need to be renamed to lede-gl-b1300.bin in both method. - the sysupgrade image can be automatically downloaded if tftp server at 192.168.1.2 have that file. - the wifi led will be flashing when writing image. Signed-off-by: Dongming Han <handongming@gl-inet.com>
Diffstat (limited to 'package/firmware/ipq-wifi/Makefile')
-rw-r--r--package/firmware/ipq-wifi/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index 9bb7428984..cc29d32136 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -13,7 +13,7 @@ endef
define Build/Compile
endef
-ALLWIFIBOARDS:=avm_fritzbox-4040
+ALLWIFIBOARDS:=avm_fritzbox-4040 glinet_gl-b1300
ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
define Package/ipq-wifi-default
@@ -48,5 +48,6 @@ Don't install it for any other device!
endef
$(eval $(call generate-ipq-wifi-package,avm_fritzbox-4040,board-avm_fritzbox-4040.bin,AVM FRITZ!Box 4040))
+$(eval $(call generate-ipq-wifi-package,glinet_gl-b1300,board-glinet_gl-b1300.bin,GL.iNet GL-B1300))
$(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))