aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/intel-microcode
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2018-11-20 17:20:44 +0100
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:44 +0100
commit022ffb56b2491fd7d8051ac6e6c7622ecc313d8f (patch)
treea6554c3eb6644284e6f4f5e7de3bbc5479fabce1 /package/firmware/intel-microcode
parent546fced2a23557e95dd34246744c3aa6cad92fe6 (diff)
downloadupstream-022ffb56b2491fd7d8051ac6e6c7622ecc313d8f.tar.gz
upstream-022ffb56b2491fd7d8051ac6e6c7622ecc313d8f.tar.bz2
upstream-022ffb56b2491fd7d8051ac6e6c7622ecc313d8f.zip
intel-microcode: create early load microcode image
Create initrd image with packed microcode. This'll allow to load it at early boot stage. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/firmware/intel-microcode')
-rw-r--r--package/firmware/intel-microcode/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/firmware/intel-microcode/Makefile b/package/firmware/intel-microcode/Makefile
index 07db9b1f96..4bd47b087a 100644
--- a/package/firmware/intel-microcode/Makefile
+++ b/package/firmware/intel-microcode/Makefile
@@ -35,15 +35,17 @@ define Package/intel-microcode
endef
define Build/Compile
- IUCODE_TOOL=$(STAGING_DIR)/../host/bin/iucode_tool $(MAKE) -C $(PKG_BUILD_DIR)
- mkdir $(PKG_BUILD_DIR)/intel-ucode-ipkg
- $(STAGING_DIR)/../host/bin/iucode_tool -q \
- --write-firmware=$(PKG_BUILD_DIR)/intel-ucode-ipkg $(PKG_BUILD_DIR)/$(MICROCODE).bin
+ IUCODE_TOOL=$(STAGING_DIR)/../host/bin/iucode_tool \
+ $(MAKE) -C $(PKG_BUILD_DIR)
+ $(STAGING_DIR)/../host/bin/iucode_tool -q --mini-earlyfw \
+ --write-earlyfw=$(PKG_BUILD_DIR)/intel-ucode.cpio \
+ $(PKG_BUILD_DIR)/$(MICROCODE).bin
endef
define Package/intel-microcode/install
- $(INSTALL_DIR) $(1)/lib/firmware/intel-ucode
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/intel-ucode-ipkg/* $(1)/lib/firmware/intel-ucode
+ $(INSTALL_DIR) $(1)/boot
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/intel-ucode.cpio \
+ $(1)/boot/intel-ucode.img
endef
$(eval $(call BuildPackage,intel-microcode))