aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-02-10 18:27:45 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-02-11 19:02:41 +0100
commit465044d0fdc2c5016766b106a53d492a1bf86b80 (patch)
tree55adc7cc06aca4095abab45c93a0750fb3eb501f /package/firmware/ath10k-firmware/Makefile
parent0dc48905cb1a11025cf3e362dc9940d92a8d8855 (diff)
downloadupstream-465044d0fdc2c5016766b106a53d492a1bf86b80.tar.gz
upstream-465044d0fdc2c5016766b106a53d492a1bf86b80.tar.bz2
upstream-465044d0fdc2c5016766b106a53d492a1bf86b80.zip
ath10k-firmware: update Candela Tech firmware images
Release notes since last time: 2019-02-08: Fix rate-ctrl assert related to bad logic that tried to guess that lower bandwidth probes were automatically successful if higher was. The NSS mismatch that can happen here caused the assert. Just comment out the offending code (per comment from original QCA code). This is bug 69. 2019-02-10: Fix bssid mis-alignment that broke 4-addr vlan mode (bug 67). Original buggy commit was commit 2bf89e70ecd1 ("dev-ds: Better packing of wal_vdev struct.") Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/firmware/ath10k-firmware/Makefile')
-rw-r--r--package/firmware/ath10k-firmware/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 71e03703cf..3ad4583459 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -94,62 +94,62 @@ endef
$(eval $(call Download,ath10k-firmware-qca9887-ct-htt))
-QCA99X0_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.003
+QCA99X0_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.004
define Download/ath10k-firmware-qca99x0-ct
$(call Download/ct-firmware,QCA99X0,ath10k-10-4b)
- HASH:=6685623e2ee75909f734e45ae9321b9f78b18ed8c585eadef88f951b8aa4b3be
+ HASH:=e3876b50cbd095f406a5d8eff310148bbef51ddc07d37af51494e35e9a19590d
endef
$(eval $(call Download,ath10k-firmware-qca99x0-ct))
-QCA99X0_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.003
+QCA99X0_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.004
define Download/ath10k-firmware-qca99x0-ct-htt
$(call Download/ct-firmware-htt,QCA99X0,ath10k-10-4b)
- HASH:=ea5ccdc88a1371e958b4b5e7657782b1bcc55ac24e11e6fa36a3fce2746be4d6
+ HASH:=59c67a9707fe5c3c632cc19f4b35814abe948dc07274e9aa1095a4e838840388
endef
$(eval $(call Download,ath10k-firmware-qca99x0-ct-htt))
-QCA9984_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.003
+QCA9984_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.004
define Download/ath10k-firmware-qca9984-ct
$(call Download/ct-firmware,QCA9984,ath10k-9984-10-4b)
- HASH:=0815fffb4757596a5ee41efb8353fb90667e4c26363fbd62a5ccf269e9a55938
+ HASH:=96fc12fc46f8520d2f36a081058e214325037313ae48afe245101466e027b6b0
endef
$(eval $(call Download,ath10k-firmware-qca9984-ct))
-QCA9984_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.003
+QCA9984_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.004
define Download/ath10k-firmware-qca9984-ct-htt
$(call Download/ct-firmware-htt,QCA9984,ath10k-9984-10-4b)
- HASH:=425b66e51039f1970802940c864ad3d6b743926e310006f6601acb9689144315
+ HASH:=7f1211c64b52ab59fc2efb39e7a279847e426de96eeff1e017becea8663f798d
endef
$(eval $(call Download,ath10k-firmware-qca9984-ct-htt))
-QCA4019_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.003
+QCA4019_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.004
define Download/ath10k-firmware-qca4019-ct
$(call Download/ct-firmware,QCA4019,ath10k-4019-10-4b)
- HASH:=6e9171d012b50053b04572933b619927070b95fd2d8b9274a3e59a374088a09d
+ HASH:=47fc0409b9766cce3718342ea8d272f0153459450bc1833d44a72a1884e81f11
endef
$(eval $(call Download,ath10k-firmware-qca4019-ct))
-QCA4019_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.003
+QCA4019_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.004
define Download/ath10k-firmware-qca4019-ct-htt
$(call Download/ct-firmware-htt,QCA4019,ath10k-4019-10-4b)
- HASH:=b265428fadda7e3ac33ef977ba1a13788914689110275e57bba7796c583f8480
+ HASH:=fb376ccde84b9a013aafc4ab2db573d0e982ae398aa647042c6f917559293a3a
endef
$(eval $(call Download,ath10k-firmware-qca4019-ct-htt))
-QCA9888_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.003
+QCA9888_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-12.bin-lede.004
define Download/ath10k-firmware-qca9888-ct
$(call Download/ct-firmware,QCA9888,ath10k-9888-10-4b)
- HASH:=fba3ce709cd0e17abec260639034bc99b0157f36c044713201cff2e5b408a6e2
+ HASH:=beb4e2973330c7640e036500f8d2c68fc428a9b2266a077aebb8e8e798eca75c
endef
$(eval $(call Download,ath10k-firmware-qca9888-ct))
-QCA9888_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.003
+QCA9888_FIRMWARE_FILE_CT_HTT:=firmware-5-ct-full-htt-mgt-community-12.bin-lede.004
define Download/ath10k-firmware-qca9888-ct-htt
$(call Download/ct-firmware-htt,QCA9888,ath10k-9888-10-4b)
- HASH:=943c0ec1967a41f16e27fd1dfebefc9196412d48d4deba204b157bd7b9b90512
+ HASH:=15fa57f6c5752877d7c96a05d2301f7eccd01832bc07d15d33246b8c06890d4c
endef
$(eval $(call Download,ath10k-firmware-qca9888-ct-htt))