aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware/Makefile
diff options
context:
space:
mode:
authorPavel Kubelun <be.dissent@gmail.com>2017-06-08 09:06:27 +0300
committerFelix Fietkau <nbd@nbd.name>2017-06-17 11:51:41 +0200
commit189239ade353636f9e2788cd0467bcca97bb9324 (patch)
tree4b84e19c6815180f18b09e257ad788f4978eb0ed /package/firmware/ath10k-firmware/Makefile
parent025cb640cdf27f7c68fc1d89d0698605daa06c43 (diff)
downloadupstream-189239ade353636f9e2788cd0467bcca97bb9324.tar.gz
upstream-189239ade353636f9e2788cd0467bcca97bb9324.tar.bz2
upstream-189239ade353636f9e2788cd0467bcca97bb9324.zip
ipq806x: qca99xx: fix wifi calibration
As of now OTP is being correctly parsed and the driver requires to parse pre-caldata to follow corresponding routine. Rename cal file into pre-calfile so the board initialized correctly with API 2 board data (board-2.bin). Also remove the now unneeded for qca9984 board.bin symlink to 5GHz calfile. Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
Diffstat (limited to 'package/firmware/ath10k-firmware/Makefile')
-rw-r--r--package/firmware/ath10k-firmware/Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 17ff2ca8e7..d33f650db3 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -319,9 +319,6 @@ endef
define Package/ath10k-firmware-qca9984/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9984/hw1.0
- ln -s \
- ../../cal-pci-0000:01:00.0.bin \
- $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board.bin
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
$(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin
@@ -332,9 +329,6 @@ endef
define Package/ath10k-firmware-qca9984-ct/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9984/hw1.0
- ln -s \
- ../../cal-pci-0000:01:00.0.bin \
- $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board.bin
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
$(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin