aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-01 18:22:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-01 18:22:01 +0000
commit64175a0ded3a2f390d985452c0bcb11350bac3e5 (patch)
treec2bf3d0e96906797339230fbdb5c75a268fb9f1e /package/firewall/Makefile
parent29da0b6c6cb1a2db0f0f05cbc346ed9963feecff (diff)
downloadupstream-64175a0ded3a2f390d985452c0bcb11350bac3e5.tar.gz
upstream-64175a0ded3a2f390d985452c0bcb11350bac3e5.tar.bz2
upstream-64175a0ded3a2f390d985452c0bcb11350bac3e5.zip
[package] firewall:
- replace uci firewall with a modular dual stack implementation developed by Malte S. Stretz - bump version to 2 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21286 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall/Makefile')
-rw-r--r--package/firewall/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index abc6020434..22d359939f 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,8 +8,8 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_VERSION:=1
-PKG_RELEASE:=10
+PKG_VERSION:=2
+PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
@@ -36,13 +36,15 @@ endef
define Package/firewall/install
$(INSTALL_DIR) $(1)/lib/firewall
- $(INSTALL_DATA) ./files/uci_firewall.sh $(1)/lib/firewall
+ $(INSTALL_DATA) ./files/lib/*.sh $(1)/lib/firewall
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) ./files/bin/fw $(1)/sbin
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
$(INSTALL_DIR) $(1)/etc/init.d/
$(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_DATA) ./files/20-firewall $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) ./files/firewall.user $(1)/etc
endef