aboutsummaryrefslogtreecommitdiffstats
path: root/package/fbtest/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-02-08 10:20:13 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-02-08 10:20:13 +0000
commit8099f4e0d3af85af483dc8755b5d3f005ba092fb (patch)
treed2d7fd9ec71e763c4ca4ddc7d4921a1d44f20f72 /package/fbtest/Makefile
parentf35c4a3266bf655a177356e3e9b3a6df1d8e842e (diff)
downloadupstream-8099f4e0d3af85af483dc8755b5d3f005ba092fb.tar.gz
upstream-8099f4e0d3af85af483dc8755b5d3f005ba092fb.tar.bz2
upstream-8099f4e0d3af85af483dc8755b5d3f005ba092fb.zip
fbtest utility
SVN-Revision: 30369
Diffstat (limited to 'package/fbtest/Makefile')
-rw-r--r--package/fbtest/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/package/fbtest/Makefile b/package/fbtest/Makefile
new file mode 100644
index 0000000000..05e67cb63a
--- /dev/null
+++ b/package/fbtest/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fbtest
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fbtest
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Frame buffer device testing tool
+ DEPENDS:=@DISPLAY_SUPPORT
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -Wall" \
+ LDFLAGS="$(TARGET_LDFLAGS)"
+endef
+
+define Package/fbtest/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/fbtest $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,fbtest))