aboutsummaryrefslogtreecommitdiffstats
path: root/package/dsniff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-12 20:18:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-12 20:18:17 +0000
commit322df2f099951391f1945058c1bf339921680248 (patch)
treee1ac99bb7cbf505f41ac51e71b5af2e8c8dff34b /package/dsniff
parent6ab192d4841801badc6cbde045aeb62f3406fdd6 (diff)
downloadupstream-322df2f099951391f1945058c1bf339921680248.tar.gz
upstream-322df2f099951391f1945058c1bf339921680248.tar.bz2
upstream-322df2f099951391f1945058c1bf339921680248.zip
add --without-x to dsniff compile and add mostlyclean target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1222 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dsniff')
-rw-r--r--package/dsniff/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/dsniff/Makefile b/package/dsniff/Makefile
index 6d6b6064ba..3355eb88d9 100644
--- a/package/dsniff/Makefile
+++ b/package/dsniff/Makefile
@@ -43,6 +43,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--sbindir=/usr/sbin \
--sysconfdir=/etc \
--without-db \
+ --without-x \
--with-gdbm="$(STAGING_DIR)/usr" \
--with-libnids="$(STAGING_DIR)/usr" \
--with-libpcap="$(STAGING_DIR)/usr" \
@@ -69,3 +70,7 @@ $(IPKG_DSNIFF):
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/* $(IDIR_DSNIFF)/usr/lib
$(RSTRIP) $(IDIR_DSNIFF)
$(IPKG_BUILD) $(IDIR_DSNIFF) $(PACKAGE_DIR)
+
+mostlyclean:
+ make -C $(PKG_BUILD_DIR) clean
+ rm $(PKG_BUILD_DIR)/.built