aboutsummaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 23:34:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 23:34:57 +0000
commitd6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6 (patch)
tree1c89b5d49f389d2b7c55d38ca165c6c16f184aa2 /package/dropbear
parent7ae75032c1ad9b23f6b4e8e2c9bb45f6cf3991bf (diff)
downloadupstream-d6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6.tar.gz
upstream-d6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6.tar.bz2
upstream-d6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6.zip
various configure related cleanups
SVN-Revision: 6372
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Makefile55
1 files changed, 17 insertions, 38 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 9dba9f4a7c..23e125e7cf 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -41,47 +41,26 @@ define Package/dropbearconvert
TITLE:=Utility for converting SSH keys
endef
+CONFIGURE_ARGS += \
+ --with-shared \
+ --disable-pam \
+ --enable-openpty \
+ --enable-syslog \
+ --disable-shadow \
+ --disable-lastlog \
+ --disable-utmp \
+ --disable-utmpx \
+ --disable-wtmp \
+ --disable-wtmpx \
+ --disable-loginfunc \
+ --disable-pututline \
+ --disable-pututxline \
+ --disable-zlib
+
define Build/Configure
$(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
$(SED) 's,^#define DO_HOST_LOOKUP,/* & */,g' $(PKG_BUILD_DIR)/options.h
- (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --with-shared \
- --disable-pam \
- --enable-openpty \
- --enable-syslog \
- --disable-shadow \
- --disable-lastlog \
- --disable-utmp \
- --disable-utmpx \
- --disable-wtmp \
- --disable-wtmpx \
- --disable-loginfunc \
- --disable-pututline \
- --disable-pututxline \
- --disable-zlib \
- );
+ $(call Build/Configure/Default)
endef
define Build/Compile