aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-04-23 13:40:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-04-23 13:40:50 +0000
commit6f5203228f32eb66db5f5c1e87066301d1ce0d9b (patch)
treef7e7373218a2fe2bdbd7e154763c57e7233fa16c /package/dnsmasq
parent819114e3f29079c52075e16fd9aa95b5adc62da1 (diff)
downloadupstream-6f5203228f32eb66db5f5c1e87066301d1ce0d9b.tar.gz
upstream-6f5203228f32eb66db5f5c1e87066301d1ce0d9b.tar.bz2
upstream-6f5203228f32eb66db5f5c1e87066301d1ce0d9b.zip
dnsmasq: - when processing domain entries, append searchdomain to host entries if they are not fully qualified - create only one reverse record for address entries with multiple names
SVN-Revision: 21109
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/files/dnsmasq.init14
2 files changed, 12 insertions, 4 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index abf0962c37..77b8f82a67 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.52
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index 47c4c2d2e6..15f856d4e5 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -296,9 +296,17 @@ dhcp_domain_add() {
local raddr="${4:+$4.$3.$2.$1.in-addr.arpa}"
for name in $names; do
- append args "-A /$name/$ip"
- [ -n "$raddr" ] && \
- append args "--ptr-record=$raddr,$name"
+ local fqdn="$name"
+
+ [ "${fqdn%.*}" == "$fqdn" ] && \
+ fqdn="$fqdn${DOMAIN:+.$DOMAIN}"
+
+ append args "-A /$fqdn/$ip"
+
+ [ -n "$raddr" ] && {
+ append args "--ptr-record=$raddr,$fqdn"
+ raddr=""
+ }
done
}