aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorMarek BehĂșn <kabel@blackhole.sk>2020-09-26 21:42:52 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2020-10-11 16:16:24 +0200
commitd4161798dd4061bd861aac5b34bca0e2900bc3fd (patch)
tree79eaf4dbef378ddbf36b1e89aef18605b5ac3260 /package/devel
parent156b72b9aa36353f0c45983c9a49c83c49865a41 (diff)
downloadupstream-d4161798dd4061bd861aac5b34bca0e2900bc3fd.tar.gz
upstream-d4161798dd4061bd861aac5b34bca0e2900bc3fd.tar.bz2
upstream-d4161798dd4061bd861aac5b34bca0e2900bc3fd.zip
perf: fix building with musl when NLS is enabled
This package fails with a strange error when building with musl when NLS is enabled. The configuration thinks that libelf is not present, even though DEPENDS contains +libelf, because when NLS is enabled, libelf.so depends on libintl, and the correct LDFLAGS are missing for libintl-full. This then causes the configuration script to check for glibc, but this fails because we are using musl. Signed-off-by: Marek BehĂșn <kabel@blackhole.sk>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 3bb403916b..e611d5eca3 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -22,6 +22,7 @@ PKG_FLAGS:=nonshared
PKG_BUILD_DIR:=$(LINUX_DIR)/tools/perf-$(TARGET_DIR_NAME)
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/perf
SECTION:=devel
@@ -38,6 +39,8 @@ endef
HOST_CFLAGS += -I$(LINUX_DIR)/tools/include
+TARGET_LDFLAGS += $(INTL_LDFLAGS)
+
MAKE_FLAGS = \
ARCH="$(LINUX_KARCH)" \
NO_LIBPERL=1 \