aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-05 15:11:07 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-07 14:53:26 +0200
commitbf136c637c02c154c14bbf48ac2c07467d948ac7 (patch)
treea2c70b8a25b9b3885311f743ff450675d6d76037 /package/devel
parentc3bdb89e61084278a598d5af15da274cada1ecc6 (diff)
downloadupstream-bf136c637c02c154c14bbf48ac2c07467d948ac7.tar.gz
upstream-bf136c637c02c154c14bbf48ac2c07467d948ac7.tar.bz2
upstream-bf136c637c02c154c14bbf48ac2c07467d948ac7.zip
perf: remove linux 4.4 workarounds
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile6
-rw-r--r--package/devel/perf/musl-compat.h43
-rw-r--r--package/devel/perf/musl-include/asm/errno.h8
-rw-r--r--package/devel/perf/musl-include/string.h18
4 files changed, 0 insertions, 75 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 61388580d5..4defdd8c4e 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -61,12 +61,6 @@ MAKE_FLAGS = \
WERROR=0 \
prefix=/usr
-ifdef CONFIG_LINUX_4_4
-ifdef CONFIG_USE_MUSL
- MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
-endif
-endif
-
define Build/Compile
+$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
-C $(PKG_BUILD_DIR) \
diff --git a/package/devel/perf/musl-compat.h b/package/devel/perf/musl-compat.h
deleted file mode 100644
index 83aa00a7c8..0000000000
--- a/package/devel/perf/musl-compat.h
+++ /dev/null
@@ -1,43 +0,0 @@
-#ifndef __PERF_MUSL_COMPAT_H
-#define __PERF_MUSL_COMPAT_H
-
-#ifndef __ASSEMBLER__
-
-#include <sys/ioctl.h>
-#include <asm/unistd.h>
-#include <unistd.h>
-#include <stdio.h>
-
-#undef _IOWR
-#undef _IOR
-#undef _IOW
-#undef _IOC
-#undef _IO
-
-#define _SC_LEVEL1_DCACHE_LINESIZE -1
-
-static inline long sysconf_wrap(int name)
-{
- FILE *f;
- int val;
-
- switch (name) {
- case _SC_LEVEL1_DCACHE_LINESIZE:
- f = fopen("/sys/devices/system/cpu/cpu0/cache/index0/coherency_line_size", "r");
- if (!f)
- return 0;
-
- if (fscanf(f, "%d", &val) != 1)
- return 0;
-
- fclose(f);
- return val;
- default:
- return sysconf(name);
- }
-}
-
-#define sysconf(_n) sysconf_wrap(_n)
-
-#endif
-#endif
diff --git a/package/devel/perf/musl-include/asm/errno.h b/package/devel/perf/musl-include/asm/errno.h
deleted file mode 100644
index 8c4b1beb52..0000000000
--- a/package/devel/perf/musl-include/asm/errno.h
+++ /dev/null
@@ -1,8 +0,0 @@
-#ifndef __MUSL_COMPAT_ASM_ERRNO_H
-#define __MUSL_COMPAT_ASM_ERRNO_H
-
-/* Avoid including different versions of errno.h, the defines (incorrectly)
- * cause a redefinition error on PowerPC */
-#include <errno.h>
-
-#endif
diff --git a/package/devel/perf/musl-include/string.h b/package/devel/perf/musl-include/string.h
deleted file mode 100644
index 65dc2f1e8f..0000000000
--- a/package/devel/perf/musl-include/string.h
+++ /dev/null
@@ -1,18 +0,0 @@
-#ifndef __MUSL_COMPAT_STRING_H
-#define __MUSL_COMPAT_STRING_H
-
-#include_next <string.h>
-
-/* Change XSI compliant version into GNU extension hackery */
-static inline char *
-gnu_strerror_r(int err, char *buf, size_t buflen)
-{
- if (strerror_r(err, buf, buflen))
- return NULL;
- return buf;
-}
-#ifdef _GNU_SOURCE
-#define strerror_r gnu_strerror_r
-#endif
-
-#endif