aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-10-19 18:50:44 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-20 12:33:40 +0200
commit9ba5cd86b89f5f51cbad536c051dca61a9bfe8e5 (patch)
tree3708099f0a6fa9608da59019bcc5f4a7a5ad3982 /package/devel
parent16f84fd275a0ee03f0faf58a40f1ba69780008e9 (diff)
downloadupstream-9ba5cd86b89f5f51cbad536c051dca61a9bfe8e5.tar.gz
upstream-9ba5cd86b89f5f51cbad536c051dca61a9bfe8e5.tar.bz2
upstream-9ba5cd86b89f5f51cbad536c051dca61a9bfe8e5.zip
strace: update to version 5.3
Makefile changes: - moves PKG_MAINTAINER above PKG_LICENSE - Change PKG_LICENSE to LGPL-2.1-or-later and correct PKG_LICENSE_FILES - changes URL to a more appropriate one, which uses HTTPS - adds 2 spaces as an indentation in description Compile and run tested on Turris Omnia, mvebu Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index 2d4332bf79..950dafc5d9 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=strace
-PKG_VERSION:=5.0
+PKG_VERSION:=5.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://strace.io/files/$(PKG_VERSION)
-PKG_HASH:=3b7ad77eb2b81dc6078046a9cc56eed5242b67b63748e7fc28f7c2daf4e647da
-
-PKG_LICENSE:=BSD-3c
-PKG_LICENSE_FILES:=COPYRIGHT
-PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
+PKG_HASH:=6c131198749656401fe3efd6b4b16a07ea867e8f530867ceae8930bbc937a047
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:paul_kranenburg:strace
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -47,13 +46,13 @@ define Package/strace
SECTION:=utils
CATEGORY:=Utilities
TITLE:=System call tracer
+ URL:=https://strace.io/
DEPENDS:=+STRACE_LIBDW:libdw +STRACE_LIBUNWIND:libunwind
- URL:=http://strace.sourceforge.net/
endef
define Package/strace/description
-A useful diagnostic, instructional, and debugging tool. Allows you to track what
-system calls a program makes while it is running.
+ A useful diagnostic, instructional, and debugging tool. Allows you to track what
+ system calls a program makes while it is running.
endef
define Package/strace/config