aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2020-04-18 10:34:10 +0200
committerHans Dedecker <dedeckeh@gmail.com>2020-04-18 10:44:30 +0200
commit5f126c541a743e2ff5d8f406128d477ab5a509b4 (patch)
tree4eeec58c834f454b4ff75e9ae328b26b638308e8 /package/devel
parent19d9db5a96d61780af6f9ca542db9593abd78526 (diff)
downloadupstream-5f126c541a743e2ff5d8f406128d477ab5a509b4.tar.gz
upstream-5f126c541a743e2ff5d8f406128d477ab5a509b4.tar.bz2
upstream-5f126c541a743e2ff5d8f406128d477ab5a509b4.zip
binutils: add ALTERNATIVES for strings (FS#3001)
Don't move strings anymore to /bin/strings to avoid clash with busybox /usr/bin/strings but move it to /usr/bin/binutils-strings. Use ALTERNATIVES support to install it as /usr/bin/strings Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/binutils/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 291f45205a..e04611f5d3 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -49,6 +49,7 @@ define Package/binutils
CATEGORY:=Development
TITLE:=binutils
DEPENDS:=+objdump +ar
+ ALTERNATIVES:=200:/usr/bin/strings:/usr/bin/binutils-strings
endef
define Package/objdump
@@ -114,7 +115,7 @@ endef
define Package/binutils/install
$(INSTALL_DIR) $(1)/usr $(1)/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ $(1)/usr/
- mv $(1)/usr/bin/strings $(1)/bin/strings
+ mv $(1)/usr/bin/strings $(1)/usr/bin/binutils-strings
rm -f $(1)/usr/bin/objdump
rm -f $(1)/usr/bin/ar
endef