aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2017-05-03 11:46:19 +0300
committerJo-Philipp Wich <jo@mein.io>2017-05-11 00:53:05 +0200
commit5dc76a4258f6f73a07b12deda73b3e5b085a7e54 (patch)
tree79fbfd6a30212bfedef4b499e4df9da92d9b5035 /package/devel
parente06d8f0f6f041c8ac1acba810eea96c32dc983e4 (diff)
downloadupstream-5dc76a4258f6f73a07b12deda73b3e5b085a7e54.tar.gz
upstream-5dc76a4258f6f73a07b12deda73b3e5b085a7e54.tar.bz2
upstream-5dc76a4258f6f73a07b12deda73b3e5b085a7e54.zip
perf: Disable perf for ARC770 only, enable for ARC HS38
Toolchain built for ARCv1 (read for ARC700 cores) by default has disabled atomic ops (-mno-atomic). When we build Linux kernel for ARC770 which has LL/SC instructions and thus may handle normally atomic ops we explicitly add "-matomic" in CFLAGS. But since user-space perf utility has no way to extract CPU config options from Kconfig/defconfig it uses compiler default settings. In case of ARCv2 (read ARC HS38) atomics are enabled by default and so perf builds perfectly fine thus reenabling perf for ARC HS38 (actually for non-ARC700 targets). Signed-off-by: Alexey Brodkin <Alexey.Brodkin@synopsys.com>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 35f1719d31..361e42278c 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/perf
SECTION:=devel
CATEGORY:=Development
- DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18 @!IN_SDK @!arc
+ DEPENDS:= +libelf1 +libdw +libpthread +librt +objdump @!LINUX_3_18 @!IN_SDK @!TARGET_arc770
TITLE:=Linux performance monitoring tool
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org