aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-21 17:51:47 -0800
committerJohn Crispin <john@phrozen.org>2020-01-15 20:34:16 +0100
commit475a504dbc05e7a7e7d38db426c657b8c0c834fd (patch)
treecaa3f118f1afd4935726b9ebb98b19066d9c591e /package/devel
parentee2014e68019c4150b9dda0cf9f140cdf6faada9 (diff)
downloadupstream-475a504dbc05e7a7e7d38db426c657b8c0c834fd.tar.gz
upstream-475a504dbc05e7a7e7d38db426c657b8c0c834fd.tar.bz2
upstream-475a504dbc05e7a7e7d38db426c657b8c0c834fd.zip
perf: Add libunwind only if selected
The depends are totally wrong. libunwind does not work with powerpc and i386 as it needs glibc. Instead of duplicating the platforms, just change the dependency. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/perf/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index 6f31c826e5..aa5fb16f60 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=perf
PKG_VERSION:=$(LINUX_VERSION)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/perf
SECTION:=devel
CATEGORY:=Development
- DEPENDS:= +libelf +libdw +(mips||mipsel||powerpc||i386||x86_64||arm||aarch64):libunwind +libpthread +librt +objdump @!IN_SDK @!TARGET_arc770 @KERNEL_PERF_EVENTS
+ DEPENDS:= +libelf +libdw +PACKAGE_libunwind:libunwind +libpthread +librt +objdump @!IN_SDK @!TARGET_arc770 @KERNEL_PERF_EVENTS
TITLE:=Linux performance monitoring tool
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org