aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-08-24 11:47:52 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-31 22:15:26 +0200
commit2b141ad392d7e948bcc9e67c7e3acd9815d1f6b8 (patch)
tree8ef8f864f10d30634fd589c0cef9fa04b0360f19 /package/devel
parent36d9ed360a34531a10883e750f076f7d76dd54fd (diff)
downloadupstream-2b141ad392d7e948bcc9e67c7e3acd9815d1f6b8.tar.gz
upstream-2b141ad392d7e948bcc9e67c7e3acd9815d1f6b8.tar.bz2
upstream-2b141ad392d7e948bcc9e67c7e3acd9815d1f6b8.zip
strace: Update to version 5.8
Deactivate multiple personalities support, because this causes compile problems at least on the x86/64 target. As OpenWrt compiles all binaries itself all binaries will use the native personality which is also used by strace. This change will make it impossible to debug i386 binaries on x86_64 OpenWrt targets for example. Just deactivate it for ARM64 too. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index cdf4067ad2..1a0c0f442f 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=strace
-PKG_VERSION:=5.5
+PKG_VERSION:=5.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://strace.io/files/$(PKG_VERSION)
-PKG_HASH:=9f58958c8e59ea62293d907d10572e352b582bd7948ed21aa28ebb47e5bf30ff
+PKG_HASH:=df4a669f7fff9cc302784085bd4b72fab216a426a3f72c892b28a537b71e7aa9
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=LGPL-2.1-or-later
@@ -32,10 +32,6 @@ include $(INCLUDE_DIR)/package.mk
HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
-ifeq ($(ARCH),aarch64)
- CONFIGURE_ARGS += --enable-mpers=check
-endif
-
CONFIGURE_VARS+= \
LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \
@@ -73,7 +69,8 @@ endef
CONFIGURE_ARGS += \
--with-libdw=$(if $(CONFIG_STRACE_LIBDW),yes,no) \
- --with-libunwind=$(if $(CONFIG_STRACE_LIBUNWIND),yes,no)
+ --with-libunwind=$(if $(CONFIG_STRACE_LIBUNWIND),yes,no) \
+ --enable-mpers=no
MAKE_FLAGS := \
CCOPT="$(TARGET_CFLAGS)"